No Audio Devices Found with 1.2 [fixed]

OS X 10.11.4 with Roon 1.2. After the upgrade, Roon is showing “No Audio Devices Found” but all of the devices are in the Settings screen. I tried changing settings and even blowing away ~/Library/Roon/{Database,Settings,Cache} but I get the same problem.

At startup, the following is in the Roon log:

04/14 09:04:30 Critical: scx: in OnExit: System.Net.Sockets.SocketException: Not enough buffer space is available
  at System.Net.Sockets.Socket.SetSocketOption (SocketOptionLevel optionLevel, SocketOptionName optionName, Int32 optionValue) <0x115092250 + 0x000c1> in <filename unknown>:0 
  at Sooloos.Broker.Transport.RaatAudioSource..ctor () <0x1241f3e20 + 0x00380> in <filename unknown>:0 
  at Sooloos.Broker.Transport.RaatZonePlayer+Endpoint..ctor (Sooloos.Broker.Transport.RaatZonePlayer zoneplayer, EndpointIntegration epi, RaatAudioDeviceBase device) <0x1241f34c0 + 0x000ce> in <filename unknown>:0 
  at Sooloos.Broker.Transport.RaatZonePlayer..ctor (Sooloos.Broker.State state, IEnumerable`1 realeps, IEnumerable`1 endpoints) <0x1241f21b0 + 0x001ce> in <filename unknown>:0 
  at Sooloos.Broker.Transport.ZonePlayerFactory.Create (Sooloos.Broker.State state, IEnumerable`1 endpoints) <0x1241f0b60 + 0x006dd> in <filename unknown>:0 
  at Sooloos.Broker.Transport.Zone.LL_UpdateEndpoints (Boolean first) <0x1241eaad0 + 0x006c3> in <filename unknown>:0 
  at Sooloos.Broker.Transport.Zone.LL_Init (IEnumerable`1 endpoints) <0x1241ea720 + 0x00047> in <filename unknown>:0 
  at Sooloos.Broker.Transport.Zone..ctor (Sooloos.Broker.State state, Sooloos.Broker.Transport.Module module, Sooid zoneid, IEnumerable`1 endpoints) <0x1241e2460 + 0x01310> in <filename unknown>:0 
  at Sooloos.Broker.Transport.Module.ev_threadexit () <0x122b86d30 + 0x02f84> in <filename unknown>:0 
  at Sooloos.SynchronizationContextThread.OnExit () <0x1150b9d80 + 0x0002e> in <filename unknown>:0

Another update – this stack trace appears only when I have a Schiit Audio Gen 3 USB audio device enabled. If I disable that device, the other audio devices appear again. Unfortunately, the problematic device is the primary DAC for this system.

Hello @Michael_Pilquist,

Would you mind to share your Roon logs ? I’ll contact you via PM for more details.


Sure, no problem at all.

Same problem on OS X after update

We have a fix prepared for this. It will be in the next release.

We don’t know why it happens on only a few machines, but not all. Most of our mac alpha testers are also on 10.11.4, as am I, and somehow none of us ran into this prior to launch. There is probably an additional factor at play. Probably something related to the networking configuration on the machine, but it is hard to say.

In the meanwhile, is it possible to go back to the previous version?

Update: for some reason I now can select my airport express. DAC still not in the device list.

I have the same problem except on Windows 10. No matter what the default audio device I have selected under Playback Devices, Roon is not seeing any of my audio outputs. I have a Maverick Audio TubeMagic D1 as my primary Roon audio output, connected via USB and optical, as well as an HDMI device and a gaming headset. Nothing appears :\

Disregard – a simple reboot fixed the problem.

Thanks for the update. Any idea when the next version will ship? If a while, is there a way to get a beta version? Thanks!

Hey @mpxs – we have a release in testing now, so expect it to be live as soon as we feel it’s fully stable. Our goal is by the end of the week or sooner.

Sorry again for the trouble here and thanks for your patience!

1 Like

Happy to report that build 128 fixes this issue. Thanks!

1 Like

Works like a charm!

1 Like

3 posts were split to a new topic: Roon wont recognize my audio devices