No Audio Devices: ROCK can't see Roon Ready zone, or local outputs [Resolved]

My Roon Controller (android) can’t see my Roon Endpoint (Oppo UDP-205). It can see the ROCK and my NAS. The OPPO is on the network. I can ping it and stream music and video to it via it’s internal software so it’s not a network issue. I have rebooted and restarted everything multiple times. It worked fine throughout the entire 2 month trial period but once my account was switch over to my lifetime membership the troubles started. First I couldn’t get logged into my Roon controller app, it seemed to think I was trying to add another instance of Roon to manage my library but that is being handled by the ROCK Core. Once I was able to get logged in I was unable to see any audio devices on my controller app. Prior to that I could see the Oppo, the local output on the android device and an Airplay device. Now, nothing. No audio devices at all.

Hi @Arthur_Ott — Thank you for the report and sorry to hear of the troubles. Let me see if we can get this figured out for you.

Moving forward, to help aide in our evaluation of this behavior you’re reporting, may I very kindly ask you for the following:

  • Since noticing this behavior with the mentioned Roon remote, have you tried reinstalling the application on the device? Additionally please also verify the make/model of this device having the problem.

  • If you have other devices acting as Roon remotes, do they exhibit the same behavior?

  • Are you by chance making use of a NAS to house your musical collection? If so please verify the make and model of this device.

  • Please provide the following screenshots from your remote device:

    • “General” tab.
    • “About” tab.
    • “Audio” tab.

Lastly, I have enabled diagnostics on your account so we can have a closer look into this behavior for you. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers. I will be sure to confirm once the report has been received.


Yes, I uninstalled the Roon app and reinstalled it, same results. I want to once again point out that this exact configuration worked flawlessly thru the 2-month trial. I changed nothing. My trial period was about to expire, it was giving me a warning in the top right corner of the screen (near the bookmark icon) so I contacted Roon to ask why my lifetime membership, purchased back in February, hadn’t kicked in. Roon made a change and everything stopped working.

I am using a Remix Android PC, basically an android tablet in a box, to run the controller app. The Roon core is running on a i7 NUC (ROCK) and my Roon Endpoint is an Oppo UDP-205. Below are the screen shots.

Hello @Arthur_Ott,

I have enabled diagnostics on your accounts so our techs can try to determine what could be causing this behavior to occur. What this action will do is the next time the application is active on your core devices a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers.

Please also describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making these connection possible.

The more information you can provide us about your configuration, the better we’ll be able to diagnose and resolve your issue in an expedient manner. I’ll be checking the support servers for the diagnostic logs, let’s get you back and playing music as quickly as we can!


My Seagate NAS is connected to my network via a 16-port Gigabit TrendNet switch which is also connected via ethernet to my Cox Cable Modem. I have a cat-5 cable run from the 16-port Gigabit TrendNet switch to an 8-port Gigabit TrendNet switch in my audio rack. The Android device running the Room Controller App, the Oppo UPD-205, my TV and my Shield-TV device are plugged into this 8-port switch.

OK, I solved it. I accessed the ROCK via the web browser interface and used the “reinstall” button to reinstall the ROCK software on the NUC. Once it was done reinstalling I was able to see the Oppo from the Roon Controller App.

1 Like

Hey Arthur – great news. Let us know if you have any more issues.

1 Like