No audio devices showing on Windows 10/11 [Resolved - Intune Firewall]

Roon Core Machine

Windows Server 2019, Dell PowerEdge T110, quad core xeon, 32GB RAM

Networking Gear & Setup Details

UniFi - most devices on wired LAN

Connected Audio Devices

USB audio DAC
Cyrus 8qx DAC

Number of Tracks in Library


Description of Issue

Roon server appears to be working fine
Roon installed on M1 Mac - all works fine - local audio devices show and Naim Uniti shows - all works as expected
Roon installed on Windows 11 machine - no local audio devices present. Streaming to Uniti or other external audio devices is fine. Also tried a fresh install of windows 10 - same issue.

I am an IT consultant and confident I have created all the necessary firewall rules etc and the LAN is functions (besides, the Mac works fine).

RAAT logs on the Windows PC shows that it sees its own audio devices:

11/10 21:27:23 Trace: [raatmanager] starting
11/10 21:27:23 Trace: [raatmanager/windows] FOUND type=wasapi id={}.{0f1ed93e-7554-4243-aed8-156f6d67f7cc} usb_id=
11/10 21:27:23 Trace: [raatmanager/windows]       name=NVIDIA High Definition Audio   output_name=DELL U2718Q                   
11/10 21:27:23 Trace: [raatmanager/windows] FOUND type=wasapi id={}.{2c135bf9-3043-4044-913e-b7d6272a02ac} usb_id=
11/10 21:27:23 Trace: [raatmanager/windows]       name=Realtek Audio                  output_name=Speakers / Headphones         
11/10 21:27:23 Trace: [raatmanager/windows] FOUND type=wasapi id={}.{448c5160-97d8-457f-abed-22e7f6e3e372} usb_id=
11/10 21:27:23 Trace: [raatmanager/windows]       name=NVIDIA High Definition Audio   output_name=DELL U2718Q                   
11/10 21:27:23 Trace: [raatmanager/windows] FOUND type=wasapi id={}.{a2b1a531-ea06-478d-b117-73d701f6f2a4} usb_id=08bb:2707
11/10 21:27:23 Trace: [raatmanager/windows]       name=USB Audio DAC                  output_name=Speakers                      
11/10 21:27:23 Trace: [raatmanager/windows] FOUND type=wasapi id={}.{bcb91f9d-1cc8-4605-8795-2d927d6e781f} usb_id=20b1:000a
11/10 21:27:23 Trace: [raatmanager/windows]       name=xCORE USB Audio 2.0            output_name=Speakers                      
11/10 21:27:23 Trace: [raatmanager/windows] FOUND type=wasapi id={}.{f23aeb07-6199-4617-abcb-16f682d32f2a} usb_id=
11/10 21:27:23 Trace: [raatmanager/windows]       name=NVIDIA High Definition Audio   output_name=DELL U2718Q                   
11/10 21:27:23 Trace: [raatmanager/windows] FOUND type=asio   id={A80362FF-CE76-4DD9-874A-704C57BF0D6A} usb_id=
11/10 21:27:23 Trace: [raatmanager/windows]       name=Realtek ASIO                   output_name=

Hi Roon
How do I go about getting support? I have 3 days left on my trial, and I wont want to be subscribing if I cant get this working.

Hey @Ben_Nichols,

I’m so sorry for the delay in getting back to you… we just got back to work after the weekend.

Thanks for sharing the issue you ran into, as well as the steps you’ve already tried. We’ve seen Windows’ automatic updates negatively impact the way graphics drivers work with Roon, so, I was wondering if you’d be able to:

  • restart your Windows
  • unsintall the graphics drivers
  • navigate to the manufacturer’s website and download the graphics directly from there
  • install them
  • launch Roon

Any change?


This trial coincided with me rebuilding my machine a couple of time. So I have tested on three separate installs:
Windows 11 - Insider preview
Windows 10 - fresh install from Dell factory image
Windows 11 - post upgrade from install above

All exhibit the same issue. All have been fully updated with drivers etc.

Thank you

Thanks for clarifying that, @Ben_Nichols :pray:

You mentioned that:

Roon installed on Windows 11 machine - no local audio devices present.

Are these devices visible on your Windows 11 outside of Roon or does your machine see them, but they don’t show up in Roon.

Thanks again :pray:

Yes they are, usable fine in apps such as Qobuz. Have a look in my original post, they even show up in the Roon RAATServer logs.

1 Like

Ive done some extensive testing. It appears that when launching Roon client on Windows, it makes a connection to RoonServer. That then makes a connection back to the RAATServer that is running on the Windows machine on port 9200. It appears that this connection is failing. Netstat on the Roon server shows the connection in a SYN_SENT state (meaning its not able to connect).
I have disabled all firewalls and the issue is the same. I have also run a network trace via Wireshark on the Windows client and I can see the incoming SYN request from the Roon server (this rules out any network or firewall issue, as it shows the traffic is arriving). However there is no response to the connection request. I have tried running Roon ‘As Administrator’ and this hasnt helped either.

I am having what appears a similar problem after installing Windows 11. My Bluos players are fine using the Bluos App but in Roon the Powernode 21 is showing as Roon Ready but the Pulseflex is not. When the Pulseflex does play with Roon the sound suffers from severe crackling.

Hey @Ben_Nichols,

I am in awe at your determination and efforts :star_struck: . Thank you for looking so closely into this :pray:

I’ve looped in our technical team, so they can help out with their insight.

Please, stay tuned :pray:

Hi @Ben_Nichols ,

Thanks for reaching out and for providing those details!

Just to confirm here, these were all on the same PC?

We have sometimes had issues with Realtek ASIO drivers and Roon. If you try to install the Realtek drivers via Device Manager and let Windows install the default audio drivers, is there any change?

Is there anything else that is using port 9200 on your machine? In the past we’ve had apps like Plex or Emby cause communication issues, but those typically run on port 9100.

Have you tried a fresh install of Roon as well? I have provided steps on how to reinstall Roon fresh below:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Let us know if any of these suggestions help with the issue!

Yes this has all been on the same machine.
I dont use the Realtek device. I have uninstalled the drivers and disabled the devices.
There are no other services using port 9200 and I can confirm via ‘netstat -ano’ that port 9200 is bound to the RAATServer process.

I have just reinstalled Roon and see the same issue. Oddly this time though I dont see it start up the RAATServer process at all.

Ignore that part on RAATServer not starting, it is now. I still have the odd connection issues though.

I have resolved the issue. This was caused by additional security settings applied via my work’s Intune device management service. This was causing the configured firewall exceptions to be ignored, which is why the inbound connections from the Roon Server on port 9200 were being blocked.


1 Like

Hi @Ben_Nichols ,

Thanks for the update here and for letting us know that the issue was the Intune firewall! Hope you have a continued excellent Roon experience, and please do let us know if we can assist in the future!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.