No audio on Windows 8 Desktop [VPN and Private Zones]

Hi Carl.
I have almost the same situation - no audio on my Windows 8 Pro desktop. All other audio application works fine. Latest version of Roon is installed. I have no devices listed on “Connected to this PC” section… But my Focusrite Scarlett 18i8 USB connected and works fine everywhere exept the Roon =(
Core is remote server (through VPN if that matters), and there is no audio connected there, it’s fine.
Here is the screens:

Let’s get you into your own thread Alexey so that @support has the best chance of seeing you :slight_smile:

Thank you, @andybob.

I keep trying to set up all properly and noted one more thing. On my android device (Samsung s7) i was able to get local phone audio output (just for the test) only if i run roon application on my Windows 8 desktop. If computer is off - i have no audio output on my phone… %)

I have no idea how it can be related =) Or maybe i’m doing something totally wrong? I just thought, that i can get audio output everywhere there i installed remote app (windows PC, phone). Network device (microRendu) is available all the time, no issues here. But behavior with local output on control devices is a bit strange for me…
Thanks for any help.

Can you set out details of your system including your Core and how each Remote or app is communicating with your Core. All components must be on the same subnet.

Thanks for your response, @andybob

OK, configuration as follows:
Roon core: Windows Server 2012 R2, ip There is no audio devices, just storage and core.
Roon endpoint: microRendu, ip - works as expected. Reachable and works from the .10 and .11 segments.

I have a VPN tonnel between segment .10 and .11

Roon remote 1: Windows 8 pro desktop, ip I connected to Roon core ( successfully, all works fine (metadata and so on), but i can’t get a sound from that computer. no local audio device listed.
Windows firewall rule is added for Roon, Roon is added into Kaspersky as the program-exclusion.
Roon remote 2: Samsung s7 Android, ip I connected to Roon core ( successfully, all works fine (metadata and so on), but i get a sound on the phone ONLY if i first run roon remote 1 (windows 8, After that a can shut down roon remote 1 and all works fine on the pnone. But if i first use my phone, without “Roon remote 1” running - on the phone i get “no audio device found”

Version of Roon is 1.2 (168). 64 bit (32bit for android)

I tried to install Roon Remote on the over host (windows 7 pro, ip (VPN as well) - everything went exactly as with “Roon remote 1” - everything works, but no local audio device listed.

Just to be clear. I have no issues with the network or VPN. All nodes (Roon related) is reachable to each over and so on. I have a problem with local audio output on the roon remote devices.

Idea of such configuration is simple and quite common, i think: i have a music collection stored on my home server. I want to listen that music at work and in my second flat with the Roon. I do what with Foobar without any problem.

Thanks Alexey, that will be very helpful for Support.

Ordinarily I would expect to see at least System Output under “Connected to this PC”. Are there any other audio programs running on the PC that might have exclusive control of the device ?

Is it possible to take your Remotes to the Core and connect without the VPN to see whether that changes anything ? Connection over a VPN is not officially supported and may have undefined consequences.

Edit: Private zones disappearing has occurred before with VPNs. Roon uses TCP/IP, UDP and multicast. Anything in a VPN that interferes with those can result in Private zones not being detected.

1 Like

Yes, i will try to run Roon remote in the .10 segment, i bet it will work perfectly =) But i don’t get fundamental reason for that problem. It’s just a local audio devices, network is not envolved. On my work computer i have no audio apps installed, no ASIO - just plain Realtek driver with WASAPI. And still I have “no audio device found” =(

About the private zone - yes, Android phone configured like a private zone, i’ll try to disable this and check. Thank you, @andybob !

There are multiple things that could be the problem, but Roon is not designed for VPN connection and Support can’t really help diagnose problems arising from unsupported use.

Other VPN users may be able to assist, but currently Roon just ain’t built to be completely functional through a VPN.

Sorry I can’t be more helpful here. If you do figure out a solution please post it here though as it looks like others have struck the same issue.

Ok, i understand that. So, local audio devices on the Roon’s remote PC IS communicating with the Roon core and can be listed (or not) - it depends of the network settings. It’s not logical at first sight, but I’m sure, there is some reasons for this…

Still, Roon is a great software, one of the kind. Maybe the Roon team can look into this problem later, it can make the Roon is even better!

Thanks for your help, @andybob

One thing i would try is the “port mapping”. Maybe support team can provide network ports numbers on which communication between Core and Control devices are established? I can explicity map this ports between the routers and let’s see what will change?

I’d suggest looking for UDP and multicast restrictions through the VPN.

A robust remote solution is definitely on the roadmap, but I suspect that if it were simple it would have emerged by now.

This thread has a post from Brian about port-forwarding. This thread sets out continuing issues others have had trying to use it.

Good luck !

Thank you!
The interesting thing - playback to the endpoint device connected in the same segment as the Core is working perfectly =) So, i can control and play music from my work in my home, but not vise versa =))

It does totally. Roon Server catalogs and creates output sources for any audio device attached to itself or a Roon endpoint. It is sending the data stream directly to that device via RAAT not through the local client Roon software which is nothing but a dumb control terminal. So, local device is a bit of a misnomer. For Roon Server to play to a device, IT, not the local dumb control software, needs to create an audio profile which it cannot do If it cannot query the device, whether that is due to needing to be on the same sub-net or because an end point is running a firewall which prevent such discovery; same result either way.

Thank you @Rugby, great explanation, i am already realize that :slight_smile: So my problem is all about the multicast end point discovery, multicast packets just do not go through the VPN. All I want is ability to point to output device manually, like with HQ player for example. Roon system itself is working through VPN, it’s all because of Core can not find the output devices.
Hope, some day it will be fixed.
Interesting, Android device seems to works, at least my Samsung s7 was able to connect in the end of the day from .11 segment and works fine =) Maybe this is windows client implementation issues.