No audio output on Laptop to Vanatoo Powered Speakers (rapid skipping)

Roon Nucleus 1.7, Build 505
Nucleus attached to Asus RT-1750 wireless router with cat 6 ethernet cable, High Speed internet from spectrum over Arris TM822 modem
Lenovo Laptop (Windows 10) connected via wifi.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Main system connected via USB cable from Roon Nucleus to McIntosh 5300 integrated amp. Laptop in downstairs den connected to Vanatoo T0 powered speakers with USB cable.

Roon now opens and runs on the Lenovo Laptop with windows 10 as a remote program, but any attempt to play music through the Vanatoo self-powered speakers through the USB cable results in no sound and rapid skipping of tracks. This did work briefly 2-3 weeks ago. I have verified the Vanatoo speakers on other streams with the laptop and works fine. I have reviewed all the audio settings. I saw the same problem some time ago on the main system (may have been when core was still on the desktop), but can’t remember what settings fixed it. I will try to get screenshots of settings.
The main upstairs sytem streams fine whether from Qobuz, Tidal or the Synology drive disc. The laptop audio driver is up to date.

Description Of Issue


Hi @Michael_Gormley,

Have you tried rebooting the Laptop and Speakers yet? I would give this a try first. If you have another USB cable around, it would be worth a try to see if the behavior is the same as sometimes cables do go bad.

This device setup tab looks like it has some modifications made to it, can you try pressing the “Load Defaults” button and verify if the behavior is the same with default settings?

Hi Norris,

  1. I rebooted the entire system: modem, wifi, roon nucleus, laptop, and Vanatoo powered speakers. I found I could view Roon on the laptop and play music upstairs using the downstairs laptop but nothing through the Vanatoo speakers (skips tracks every couple seconds).
  2. I then downloaded the Tidal app on the laptop and played a MQA music file through the laptop to the Vanatoo powered speakers. Worked fine. I believe the Vanatoo converter limits to 24/48 format. So USB cable, driver and Vanatoo speakers check out.
    3, I reset the audio settings for the Vanatoo to the default values and tried again. Still rapidly skips if I try playing through Roon. Doesn’t matter whether I play Tidal, Qobuz, or CD files from my Synology drive. Upstairs speakers work fine, Roon will not play through Levono laptop to Vanatoo speakers.
    Is there a log file you can view to determine what the problem is? Thanks for your help.

Hi @Michael_Gormley,

Thank you for performing those tests, this helps narrow down the behavior.

Yes, there is. Can I please ask that you reproduce this issue once more and note the exact local time + date when you attempt to play to the Vanatoo zone (e.g. 3:09PM on 12/12/19)? Once I have this information, I can go ahead and enable diagnostics mode for your Nucleus and check to see if there are additional clues contained in logs. Thanks!

On 12/12/19 at 2:07-2:10 PM MST I tried playing 1 album from Qobuz (24/48 file), 1 album from Tidal (16/44.1) and 1 album from my Synology drive (16/44.1). All skipped tracks every few seconds with no sound produced from the Vanatoo speakers. Yesterday I could use the same laptop to play music on the upstairs McIntosh system, so there is something unique with the Vanatoo speakers, but I had been able to play Roon through these when I first got the Nucleus and when I had the core on the desktop system. Hopefully the log files gives us the cause. Thanks.

Hi @Michael_Gormley,

Thank you for letting me know that timestamp. I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis. I can confirm that logs have been received and I have requested further feedback from the technical team regarding the traces. Thanks in advance for your patience!

Hello @Michael_Gormley,

I appreciate your patience while I had a chance to review logs. I’m looking over them and I notice the Vanatoo speakers are discovered, but Roon fails to start playback to them. One of the common causes of such behavior is a firewall blocking Roon from operating properly.

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall client.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path. I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have.

Thanks for your persistence in investigating. Looks like Windows Defender Firewall has allowed roon.exe and raatserver.exe (both as private). I’ll see if the screenshot works:

Now I’ll check anti-virus settings:
I added the above exceptions to AVG anti-virus software and IOBIT anti-malware program. Will reboot system and see if this works. Thanks!

Finally got problem corrected by deleting AVG anti-virus! My MS firewall should be sufficient along with a free anti-malware scans. It must have blocked the Roon app when it made an update. Good reason to get the audio endpoint off computers! Thanks for all your help!

1 Like

Hi @Michael_Gormley,

Glad to hear you were able to resolve the issue by disabling AVG!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.