No covers anymore in Roon-App on Win10

Core Machine (Operating system/System info/Roon build number)
Core: AMD 3950x, Windows 10, 64 GB RAM, RoonServer v1.7 (build 710) stable on windows

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Network: Netgear GS108E (GE-Switch)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Audio device: Creative speakers on soundcard of PC (to simplify the environment)
Controls: Roon-Apps on Win10 and on a borrowed iPad (all last versions)
Library: NAS Synology DS220j, 7.300 Albums, 110.000 Tracks, only mp3 + FLAC, no DSD, no streaming services

Description Of Issue

I’m testing Roon since 1 week now. At first all works well, but suddenly all covers disappeared in all views of the Win10 Roon control app.

The core works without problems for 2 about days. Then the covers disappeard completely. I could fix that by changing the theme from light to dark. Changing back to light again the covers disappeared again. So far, so good.

Some times later the problem occured again. Shortly before I changed in settings ‘Show format information on albums’ to ‘on’. Reversing the change brought back the covers and vice versa they’re gone again.

Now the problem occured again and both tips don’t work.

Clearing cache didn’t help (C:\Users\xxxxxxx\AppData\Local\RoonServer\Cache)
Testing with a borrowed iPad doesn’t have that problem, all works fine on that device.
Therefore I think, the problem is related to the Win10 Roon-App.

I’m not sure what to do now.

Hello @obbie, and welcome to the community! My apologies for the issue here. Does the issue resolve if you reinstall the app on the Windows machine? Have you tried switching to Google or Cloudflare DNS to see if that helps? Lastly, does this only happen for streamed content or your local content as well?

Thank you for your reply, @nuwriy. In answering your questions:

  • no, the reinstallation of Roon control app did not solve the problem
  • no, I didn’t try switching to Google or Cloudflare DNS, no idea what that means …
  • no, I don’t use any streaming services

The core and the windows app are running on the same machine.

Meanwhile I updated the Nvidia driver for my GTX 2070 Super graphics card, but the problem still occurs.
I did some fiddeling in my system and found a method, to solve the problem often for some time:

  • when the pictures (that means not only the cover art) are lost I go to settings/setup and change the value for ‘memory for Photos/Artwork’ followed by ‘clear cache’ and restart the App.
    Sometimes I have to do this 6 oder 7 times until the pictures are back again.

Minimizing Roon to taskbar and open again sometimes also results in lost pictures.
From my perspective I would guess a problem in the windows app …

P.S.: to provide the correct fieldnames of the menue to you I had to switch to the english language. Afterwards I switched back to german. But now I’m NOT able to bring back the pictures …

In 3 days my trial period ends. Under this circumstances I can not start subscribing Roon, even though it’s a great system !

@nuwriy The no-cover problem in Roon is quite old, many stuff to read. I found an advice to disable Logitech’s G-Hub Software, but with no effect. Do you got any other information about ‘maybe problematic’ applications on Win10 I could disable as a test ?

Are you running Roon GUI app or Roon Server , they are different . It sounds like you may have both running you only need one. The Server version has no GUI as such and is meant to run headless.

In the short term I would uninstall Roon Server and have the main Roon App running on windows , that will save confusion about what you area adjusting.

When you import a new album does Roon ID it OK and produce a Cover Art picture.

Hi @Mike_O_Neill,

I agree that using the same terminology avoids confusion, but I thought my wording was quite clear:

The core and the windows app are running on the same machine.

Is this misleading ? That means Roon server and Roon GUI app are running on the same machine.

the reinstallation of Roon control App did not solve the problem.

That means reinstalling the Roon GUI app did not solve the problem.
I reinstalled the Roon Server too, but that did not solve the problem neither.

When I import a new album, it always will be recognized by Roon. The cover art situation did not change, that means:
if before the import No covers where shown, after the import covers will farther NOT displayed and
if before the input covers where shown, after the import covers will farther be shown.

The no-cover problem in Roon is quite old, many stuff to read. I found an advice to disable Logitech’s G-Hub Software, but with no effect. Do you got any other information about ‘maybe problematic’ applications on Win10 I could disable as a test ?

Did you restart the Roon Server and Client process or reboot the machine after disabling the G-Hub software?

Also take look at system and Roon (Client/Server) logs to gather further information if needed. Where you can find Roon logs:

Feel free to provide a list of software you have installed. Maybe someone can spot something suspicious.

Hello @obbie, and my apologies for the continued issue here. As blackjack said, getting some logs would be the next step. When you notice the issue next, could you please reply here with the date, time, and album you noticed the issue on so I can enable diagnostics for your account? I’m also going to send you a PM with another step, please take a look!

Hey @Mike_O_Neill,

Thanks so much for working with our technical team to get this issue resolved - sorry you’ve ran into it. For now, I’ve extended your yearly subscription by 2 weeks, to cover for the past few troubleshooting days.

We’ll stay in touch, should further action be needed,

PS: Thanks @nuwriy for tagging accounts :smile:

Thank you most unexpected,but I didn’t have a problem :shushing_face:

Ooops :crazy_face:, @Mike_O_Neill - it was my fault, misreading the thread. Sorry about that.

Enjoy the extra two weeks :smile:

Ironically it’s goes from 13 Dec to Xmas Day :santa:t3:

1 Like

Merry Christmas indeed :grin:. A bit early, but, hey, there’s never a bad time for Christmas :christmas_tree:

i also have the No-Cover Problem.
Nothing helps… sometimes yes sometimes no.
Are there any solutions right now?
For this money per month not acceptable at all.

With no covers the experience is worse.


It’s probably best for you to open a new Support request for your issue, giving the full details of your setup as described here:

@Steffen_Rothammel Finally I installed the Roon core in a VirtualBox-VM under Windows 10 and everything works fine under Roon 1.7. Meanwhile I upgraded to 1.8 B783, still no problem.

Regards, Klaus

Did you update the drivers from the Nvidia site? This works mostly better then through Windows itself.

i have a MacBook Air M1.
And when this is a problem for so many people…
Is there no general solution?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.