"no database found"

Roon Core Machine

Intel NUC 8i7, 8GB RAM

Networking Gear & Setup Details

LAN

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hello, i wanted to move with my roon core to another device. I made a backup of my database on the old device, but by trying to import the backup on the new device i receive the message “no database found on device”. but it is on the device i saved the backup.

[moderated] This is one of the MOST IMPORTANT functions in roon and you made this buggy??? Sorry but from a $700 program I don’t expect anything like that to happen!!!


What did you make the backup TO? A USB hard drive, a USB stick, a NAS?

1 Like

I ask because database backups need to be made to an external location, an external USB Hard drive, an external USB flash drive, a NAS, or another network location on a PC, for example.

1 Like

From his screenshot, it appears to have been a Kingston DataTraveler 3.0 USB stick.

Personally, I don’t trust USB sticks for Roon database backups, given the nature and structure of the backup - I use USB drives instead. I suspect that the backup was corrupted when written, and thus cannot be restored.

2 Likes

Good Eyes. I agree, I don’t trust USB sticks for database backups either.

1 Like

i dont think the backup is corrupt because the FROM core can read his own backup. only the TO core cant find an backup on this usb stick :-/

So that screenshot is of the original Core?

And what was the hardware/OS used for the original Core?

no the screenshots are from the new core that cannot find a backup on the stick.

the original core was a mac mini server 2012

What format is the USB stick using? Thanks.

1 Like

exfs i think. the problem is not that the nuc cannot read the stick: he sees all files (see screenshot) but it finds no backup

It’s an odd one. Particularly since you say that the USB stick can be read and the backup found on your Mac Mini. Any chance of taking a new backup from the Mac Mini, preferably on another USB device?

i already tried this with another usb stick. same result. perhals i can try an usb harddisk but im sure that will be the same result

What version of Roon was used to make the backup and what version of Roon do you have on your new Core?

both the newest version of roon (build 1311)

so i made a new backup of the FROM core to a harddrive. this backup is found by the TO core. i imported it and restarted the new core. but then the core is not active and i cannot connect to it :frowning:

Can you post a screenshot of what you get when you try and connect? Thanks.

I think i got it. After some more restarts and reboot of the complete nuc the old database runs on the new core :hugs:

Thx 2 all 4 help but i dont know what the mistake was. I think roon dont likes usb sticks :frowning:

NOTICE: never make backups on usb stick :pensive:

2 Likes

There’s an old saw that is completely true - data does not exist unless it is in at least three different places. Consider connecting to Dropbox, and automating daily backups to that location. Then you can easily copy off to other locations for secuity. Dropbox also allows you to recover from the “oops I deleted it” moment.

1 Like

see second posting :slight_smile: