No DSP on Android DAP

DSP isn’t working on my Hiby New R6 (Android 9)
I’ve loaded and enabled a Max PCM preset (that works on my other Android device and other endpoints)


And, weirdly, this device shows up on my Core as enabled but it’s not selectable on any of my endpoints.

Other than DSP and not showing up as an endpoint anywhere it works as expected.
Any idea how I might fix this?
I’ve restarted my core and reinstalled Roon on the device.

Sounds like a private zone (default for PCs and phones/tablets). Read more:


Yes indeed thank you.
It was set as a private zone.
That resolved the device not appearing elsewhere but still no DSP.


Hi @Placebophile,

On smaller Android devices, you can toggle DSP features but not adjust them. After restarting the remote, try opening signal path in landscape mode once you have the Max PCM preset enabled and see if the DSP is presented in signal path.

You can adjust and reconfigure DSP settings with more granularity from the Core for that endpoint.

Happy to answer any questions or clarify further.

1 Like

You can’t upsample on Android to my knowledge as Roon will down sample it to a fixed rate the dap reports back to Roon it supports. If it’s like my Hiby r5 anything above 44.1/24 is automatically downsampled you can’t go higher.

1 Like

Thanks for the replies.
“No DSP” was a bit of a misnomer.
Parametric EQ and crossfeed work.
Sample rate conversion does not.
However I’ve noticed that enabling crossfeed or Parametric EQ appears to cause upsampling to 24 bit :woman_shrugging:

Yes all dsp will be performed at 64bit in Roon to reduce loss, it scales to this then its output at the highest depth the device reports which is 24bit in this case. Sample rate however will be no higher than 44.1 most likely on Hiby.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.