No Endpoints/Tracks/Music

I’m having a similar issue. My nucleus + worked send tidal, via nucleus + to lumin u1 streamer. Never had an issue .

Now roon sees no endpoints nor can I see music. There are no tidal songs displayed.

What the heck roon. Lots spent and poor performance.

Please reboot the Nucleus+ and power cycle the Lumin.

Hi Peter. Ive rebooted the nuc + a dozen times and powered down the lumin u1 many times.

None of the endpoints shown up, such as yamaha aventage 3070 receiver. And tidal doesn’t run in the roon app eventhough I’ve signed into tidal via roon.

Please power everything down on the network, including the Nucleus+, Lumin, Yamaha, iPad.

Power cycle the router, and all WiFi access points, and all network switches.

Wait for 5 minutes, then power everything up.

Tidal is a different issue. Let’s solve your endpoint visbility first. Then you can at least play your local library.

Hello @Adam_Gorberg,

Can you please use these instructions to access your Nucleus log and upload them to WeTransfer / Google Drive / Dropbox and post a link here?

From adam gorberg

Hi @Adam_Gorberg,

Thank you for sending those logs. Sometimes, errors like the one you saw can be spurious, but unfortunately in this case I am seeing signs of low level corruption in your database.

This type of error is extremely rare for us and not one that we see often. Our database infrastructure is designed specifically to prevent this type of corruption, and we don’t take this class of issue lightly.

We’ve traced a few reports like this in the past to hard drive integrity issues but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

If you’ve been making regular backups, my advice would be to install Roon fresh on your Core machine, and roll back to one of your backups. You can use these instructions to do so:

  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • Restore from backup at least a week before issues started

If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

If you do not have any backups, unfortunately you will need to start with a fresh database.

Again, this class of issue is extremely rare for us and you have our apologies for the trouble here.

I do not have any backups.

I do not use this device in any way other than its intended purpose.

Very simply, plug and play. I stream tidal and have not even installed a HDD, or added music personal library.

This is really unpleasant as I’ve spent thousands on this device and a lifetime subscription, and it is malfunctioning.

The reason I agreed to go this route was for simplicity and quality performance. I am experiencing neither at the moment.

Are we just able to replace this with a proper working device??

Hello @Adam_Gorberg,

There is not necessarily anything wrong with the device at the moment. As I mentioned in my previous post, this kind of issue happens when the data written to the drive is different than the data being read back. It is possible that a power issue caused it (if the Nucleus was improperly shut off).

I would suggest you use the instructions I have provided to set up a fresh database and set the Core up as new, once you do this, your audio devices should be visible again:

Apologies that you don’t have any backups of the database to restore from, but doing this procedure should help get the Nucleus up-and-running again. I would also suggest keeping regular Backups of your database moving forward (if you perform many edits to your library’s metadata).

If you’re recommending reinstall the OS, I already tried that.

Hi @Adam_Gorberg,

Reinstalling the Nucleus OS does not set up a fresh database, and this is an issue with the database itself. To set up the fresh database, you can use the instructions I linked above (best method) or press the Roon Database & Settings -> Reset button on the WebUI.

I see tidal and the endpoints! Your troubleshoot fixed it.

Just a note for roon folks.

The power went out a few days ago, and I believe that’s when this started. I am new to roon and the nuc + so I haven’t played with it, other than it’s most basic functions. Thank you for helping, but I hope this doesn’t happen when the power goes out. In Florida that’s a regular occurence.

I’ll look into creating backups for the future. That’s a new feature to me as well.

Thanks so much,

Hi @Adam_Gorberg,

I would try an additioal reboot of the Nucleus, but if the behavior is the same following the reboot, please try using the full database reinstall instructions I listed instead as this would be the best way to clear the old database:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.