NO gapless playback with TIDAL MQA on ifi ZEN Dac

Hey there!

The titel is pretty self-explanatory. I just returned to ROON and got myself an iFi ZEN Dac for MQA playback over TIDAL. But on several live albums (Ayreon - Ayreon Universe Live, Ayreon - Into the Electric Castle), I have very annoying half-second glitches between tracks when playing back the MQA versions from TIDAL. This does not happen with local files or local MQA files. I am on a steady wired 150Mbps Ethernet connection with Google DNS set. I hope somebody here can help me :-(, since MQA playback over TIDAL with the Zen DAC was more or less one of the selling points of coming back to ROON…

The last thing I saw was

Thanks! But seems also like a long time ago… :frowning:

If it helps, I had this issue originally on my iFi Nano Black and Zen DAC, until I updated to the iFi Firmware 5.3c. It now plays seamlessly.

However, I have found that if crossfeed is enabled, then the break recurs again, and even disabling crossfeed again won’t fix it, until the DAC as been restarted.

This only occurs with streamed MQA.


I have the same issue with my Zen Blue DAC.
Was this issue solved? Is it a software issue?



Just got an iFi Neo iDSD and this issue occurs for me as well. So far what I have seen is that turning off DSP completely works.

This issue was reported in 2019 and it’s quite surprising that it’s still in play.

I have noticed that when play full MQA albums when it switches tracks it completely goes mute. At this time the signal on the DAC display keeps switching between ORFS and DXD.

Did it on my ifi iDSD Nano too. I spoke to Ifi and they where not much help, its a quirk of their MQA implementation and seemed to happen only on Linux for me.

I updated the firmware to use their GTO filter and it seemed to sort most of the issues. But I kave no long since sold the Nano.

I had the same, tried everything but couldn’t solve the problem. Finally changed the Zen Dac for the iFi Neo iDSD. That plays the MQA files perfectly with an amazing sound…


It’s strange. I’m having the issue on my Neo iDSD. But it only happens when I have DSP on. And not always but every now and then when moving to the next track.

The fundamental difference between the zen DAC and the Neo is that the Neo is MQA decoder and renderer. But if DSP is on then the Roon core decoder comes into play irrespective.

I have captured the signal path and DAC display when this happens.

Some thoughts from @john @Jake_iFi is highly solicited.

Just moved my iFi Zen DAC to the Mac Mini (core) and yeah, issue is still there. Kind of a bummer but oh well. I have two outputs from the Mac Mini… the iFi Zen DAC goes into the 7.1 analog inputs (just front right and left channels) to basically bypass the Marantz DACs… and one optical into the Marantz which gets me up to 192kHz. So I’ll have to live with switching to the “optical zone” if I want to listen to a gapless album and forego MQA.

Disabling all DSP didn’t help on the Zen either.

Appreciate if someone from @support could please reply. This makes the listening experience sub-par for full length MQA albums using the iFi DAC which is my only device for desktop listening. I have also raised a ticket with iFi but I am not sure where the problem lies.

Can you not try it with the Tidal app and the mac and see if it’s the same? If not then it’s Roons comparability with it perhaps. But I think i it’s if implementation and the fact they are using Burr and Brown DACs that don’t have MQA processing built in like the new wave of DAC chips , they treat MQA as DSP as far as I could get from their support, they scooted around the question without really answering when I had dropouts with Linux and MQA.

Just played an entire MQA album on the TIDAL app on my Mac and not a single dropout or muted track. So the Neo iDSD definitely handles MQA properly. Its something that Roon does with the DSP processing on a MQA track that somehow confuses the DAC and causes it to go all silent. I have Headroom, Crossfeed, Audeze Preset and DSD upsampling enabled.

Ok good to have tested to see if it’s isolated just to Roon which is seems to. I have an MQA file I could try out and see if it play with DSP on my SMSL.

Listened to the same album on Roon with all DSP turned off and the DAC both decoding and rendering MQA. Again no problems whatsoever. So I think it’s obvious that DSP on MQA is what is causing the problem.

Playing mqa with DSP to my SMSL perfectly fine no mutes, dropouts at all.

Think the issue is specific to the iFi Neo iDSD and maybe some other DACs from iFi as well. At least I have no way of knowing otherwise but definitely does not occur when playing on my Oppo UDP-205 USB Audio.

Just bought the iFi Neo iDSD and discovered this issue. It’s going back: £699 is way too much money to spend on something with a flaw this significant.

I had this problem with a Nano BL. Updated the firmware to 5.3c and voilà: solved. Now I can listen to MQA tracks right from the beginning, even with DSP on.

PS. There’s a very informative discussion about this issue in Head-Fi: ifi iDSD nano BL - firmware/MQA issues | Headphone Reviews and Discussion -