No images whatsoever for the last several months

I haven’t been able to see any images whatsoever for the last several months when using Roon. It began when I tried using Wireguard to access it remotely w/ Tidal albums, and since the latest update, I don’t see any pics at all for anything in my library. It’s been taking Roon support one to two and a half weeks to respond so now I’m also working w/ the QNAP folks to see if they have any ideas. Don’t get me wrong, I love Roon, but man, there’s gotta be a better way to get help sometimes…

There doesn’t seem to be any posts about it from you here. All your posts are in the Tinkering section about VPNs.

1 Like

If I were to guess I’d suspect the VPN isn’t forwarding the ports that data is carried over.
I have no clue how metadata is handled vs audio data. I’d guess different sources, different ports.
Lots of guessing.
Does it work without the VPN?

Morning. Thank you @ged_hickman1 and @MamaTried for your replies. I believe someone moved my comment off the thread because it’s a different topic. I debated about submitting this on that thread, I should’ve listened to my gut and held my tongue.

That aside, there are no pics showing, regardless of whether VPN is active or not, and whether or not I am at home. Reading through Aaron’s thread about his udp-proxy, someone else mentioned having their Roon server on a QNAP NAS, but I don’t want to bother too many people about this as I seem to be the only one with this problem. I recently updated to their new QTS 5.0.0 firmware update and I’m waiting to hear back from QNAP to see if it might have effected this.

No need to reply. I really appreciate you both taking the time to give me feedback. Take care.

1 Like

Hey @bymatty,

Thank you for clarifying here that your troubles began with your attempt to get Roon to work with VPN. We have no problem with our customer’s desire to experiment with Roon and figure out new and creative ways to get it to work on their systems.

However, Roon via VPN isn’t a supported. If attempting to get Roon to work this way broke basic functionality and features of the software, we recommend putting your head together with some of our other users who have gotten this to work for them. i’m moving this thread over to tinkering. We wish you the best of luck!

No, Please @jamie this has nothing to do w/ VPN! That’s a totally separate topic! Please, please look at the thread Metadata Not Loading After Adding New Album. The lack of pictures/metadata has nothing to do w/ VPN. I don’t understand where the misunderstanding is.

Please help me.

This has been since the last update.
Are you running a firewall on that device? Did you update firewall ports?
I believe Roon changed ports.

Hello @MamaTried. I have a Netgate 6100 running PfSense+ being used as a firewall/router that connects my QNAP TVS-672N running the Roon core to the rest of my home network. How do I update the ports? Doesn’t that happen automatically?

If it updated automatically it is using uPNP. Odds are that isn’t working properly.
VPNs will consume your routes if you do not understand how they work.

Disable the VPN and firewall MOMENTARILY. Do your images return?

How to Open Ports in a Netgate pfSense Router (

This lack of pictures is due to something on your local network blocking comms with the Roon picture services. In the later releases roon moved some of the ports and as your own initial post said “It began when I tried using Wireguard to access it remotely” so it sounds like you have something blocking locally.

1 Like

Thank ou @MamaTried and @ged_hickman1. I turn off Wireguard when I’m at home, but I’ll look into how VPNs consume my routes. Hopefully I can find something on it.

When Roon support initially contacted me they had me try using Roon Core on my Mac (this was back in Nov I believe). The pics all loaded fine. Today however, it doesn’t. So, I believe that also confirms something’s blocking it on the inside.

I’ll check into the uPnP thing, disable the firewall for a sec and see if I can figure out about the ports. Maybe there’s a way I can disable PfBlocker on my PfSense first to see if that’s the issue, or check the logs kept by the firewall. I doubt there’s anything that’ll say, “Such & such program blocked Roon request for pics.” But wouldn’t it be nice if it did though?

1 Like

Try opening
UDP 9003, TCP 9100-9200

Morning. I opened port UDP 9003, and TCP 9100-9200, along w/ the corresponding rules, but that hasn’t worked. I saw uPnP wasn’t activated, so I activated that as well, but that hasn’t effected anything either. Considering the uPnP has never been activated when Roon initially worked, I’m not sure that’s the problem.

I also tried disabling the firewall, turning my Netgate into a router only, but then my internet wasn’t working at all. Not sure if I gave it enough time, but I didn’t want to leave things open too long.

It was also soon after updateing QNAP’s QTS 4.5.4 firmware to QTS 5.0.0 that I began to see issues w/ Roon as well. The QNAP folks said that’s a possibility, so I’m debating whether to try going back to QTS 4.5.4. The other option I guess is to just reset the Netgate 6100 to factory defaults and start all over again.

I think you need to sort out your local network. Get it to a steady state without the vpn and get Roon working.

Your pfsense box is also probably doing natd (Internal translations). Turning off the router (routing) is very different from, disabling a firewall.

It will take some time to do it right. a quick try here and there will never get it working.
In my experience.

1 Like

Thank you @MamaTried. Reading what you said, it might be easier to just do the reset and start from the beginning. I tried searching for how VPNs effect routes, but there was nothing I could find. I’m assuming it might have something to do w/ having a residual effect, regardless of whether I’m using the VPN or not. I kind of hope that’s not the case, because I need to use a VPN when off my network for security needs required for my work.

I really appreciate your help and timely reply’s. It’s so nice to get timely feedback, despite how hard it might be to hear. It makes it easier for me to just fix it and move on. So thank you very much!

1 Like

I have the same problems as you have, pictures will not load,Tidal are wery slow, And Qobuz will not load at all, the issues started after the last update, but sometimes everything can start to work ass it shall, but its only some hours for the moustly, when it works ass it shall, qobuz works perfect and i also think that the souns quality is a bit better,that the sound is a bit more open.
I have tried everything with my network, but I’m not any expert
Yesterday I tried to reinstall one of my old backup files from early in December I think, I have the files on Dropbox, and after I did this everything worked smoothly and perfect. For a while.
I thought that I should try do the same again, but i also have big problems with Roon and logg into Dropbox,
So I’m thinking about to throw the Nucleus out of the window and start streaming without Roon. I don’t know but I’m tired of this😂

I have Ethernet cable from my internet central in to the house i have fibre cable with 1000gbs speed
Now the Ethernet cable goes too my HIFI Switch and cable from English Electric EES8 Switch to Nucleus.
Now I have Wi-Fi only at my internet central,but I have tried different routers and everything but nothing help’s
Back to the sound quality, I have a great and expensive stereo system, with good quality components, line source speakers with super tweeter’s, so it’s so easy to hear when it’s something wrong with the sound, Think about it and let me know if you want

Add images

Hello @Morten_Saether thank you for your input. I’m sorry you seem to have similar problems as I. Have you also included a VPN in your network? That seems to be a sticking point for whether it’s an issue w/ the Roon update itself, or if the problem results from making changes to ones network that affect its functionality. At least in my case.

Your write up talks about troubleshooting you’ve done, but also talk about sound issues as well. I’m not exactly sure if you’re asking me something in particular, or if you’re just adding your experience w/ this.

For what it’s worth, when I logged out of the Roon core on my NAS and switched to having the Roon core on my MacBook Pro a few months ago, the pictures returned. I saved that version as a backup, logged out, and logged back in to the Roon core on my NAS. When I restored the backup I had made from my laptop, the pictures did not load. I’m glad to hear you didn’t have that problem.

I would recommend using ethernet cable as much as possible to connect the Roon core to where you store your music, and to where your sound system is. The use of wifi opens up too many confounding variables. Having your phone or tablet connected via wifi is fine because it’s just controlling the music playing on your system.

1 Like

Hello thanks for your reply.
Well I found the issue on my system and Roon was not the main problem.
I took a last check on my Ethernet system, and recognized that my Ethernet cable was connected to the M2M port on my internet/home/fiber cable central.
The M2M port should be moist used for television and multimedia I think, so I move the connection to Lan 3 and the problem was solved.
I don’t know why this is happening now, because I have been using this port for months without any issue’s, but i read something about that Roon Labs have closed some port’s in the last update.
Maybe your problem can be here too?

Thank you Morten for the feedback. I don’t think I have an, “M2M,” port on my Netgate and I’m not too sure what it is. A quick Google search talks about an older type of ethernet or WiFi port. But checking cabling and setup is an oversight easily made and appreciate the insight. I’ll take a look, but after that I’m not sure where to go.

I shut off and disconnected all my internet devices, reset the Netgate 6100 to factory defaults and set it up from scratch. I tried Roon and it didn’t work. I then removed the Roon app from my QNAP TVS-672N, changed firmware back to 4.5.4, downloaded the Roon app again and setup Roon from scratch (I.E. didn’t restore from backup), and it still doesn’t work. So, with the firewall router setup exactly as it was when Roon had been working 4-5 months ago (and no Wireguard), I continue to have the problem of not seeing any pictures. The only thing I seem to have accomplished is now I’m seeing more ads, especially on various apps I use on my phone. I also tried forwarding the ports mentioned earlier and that still doesn’t work either. I’ve attached some more screenshots to show the extent of the issue. I’m not sure why 3 album covers show, but the rest do not. Regardless, as soon as I tap on the album to go play it, the picture disappears on the next page.

If anyone has additional ideas, I’m open to them. It does appear something might be blocking the pics, but I don’t know what or how to find out. There are the logs, but I don’t know what to look for or which logs to look at.

What is your DNS set to? The Netgate shows defaulted in the manual. Is it You can also try which is Cloudflare. Sometimes DNS issues can result in image loss.

1 Like