No monitoring of directories

Sorry to have to say this.
But it’s always the same: nobody wants to know anything and help solve the problem.
Whether it’s PLEX (there are other annoying problems, which is why I don’t use it at home anymore…) or Roon: from my point of view, the supplier of the software would have to intercept a problem of the platform used programmatically or provide a manual with which one can solve it.
If one of them puts the blame on the other, it is of little use: certainly not to the end user.
Be that as it may, I solve the problem with a daily reboot, which is not nice but at least solves the problem.

You can initiate a forced rescan instead, which is much nicer. How to do it is documented in:

Thanks. Yes I know that. Both are possibile.

@BlackJack - Just wanted to say “thanks” for helping in the forum as you do.

@Lukas_Metzler - I think you’re falling through the cracks, so to speak. Your issue could be caused by:

  • A Synology bug in which change notifications aren’t generated consistently
  • A Roon bug impacting notification registration or response
  • A package issue, assuming you’re running the RoonOnNAS package created by a community/form member

After reading the thread, my guess is that it might be a Synology bug that specifically impacts changes made via SMB.

I think you’re going to continue to have a difficult time getting Roon to engage with you on this issue because the evidence suggests that it isn’t there issue. Specifically, the fact that using Synology’s File Station to make changes works suggests that Roon is registered for changes and responds to them.

If you want to continue to debug this issue, you might try looking at the SMB “Advanced Settings” on your NAS. If you dig around deep enough in there, you’ll find a setting for “Monitoring changes on all subfolders within the directory”. Perhaps that will help, though I believe it already defaults to enabled. You can also enable debug logs for SMB and maybe you’ll see something there.

I considered suggesting that you try running Roon in a docker container, assuming you’re currently running the package version, but I think there’s a good chance that this wouldn’t help.

At the risk of stating the obvious - since using Synology’s File Station UX seems to work for you…you might create a folder called “Temp” or “Staging” or something like that within your Music folder, move stuff into that folder using Windows and then just use File Station to move it to the final location. It’s not perfect but it might be less frustrating than what you’re doing now.

Good luck…hope you figure something out.

1 Like

I found a solution that works for me now on synology DSM 7.1 (Thanks to Ben for his solution posted on forum.syncthing.net):
"FYI here’s what works on a DS916+ running DSM 6.1.7: go to Control Panel > Task Scheduler. Create a New Task > Triggered Task > User-defined script.

In General Settings tab: give it a name (e.g. “Syncthing sysctl inotify fix”) and Event = Boot-up.
In the Task Settings tab: enter this in the Run Command box:

sh -c ‘(sleep 90 && echo 204800 > /proc/sys/fs/inotify/max_user_watches)&’

The sleep is to delay the setting to (hopefully) skip past any initialisation that Synology do at boot. Seems to work for me.

Click Ok to close the task dialog, then enable the task and hit the Save button."

Restart your DSM after that.

There’s a link in this very thread to that solution already posted on the Roon forum :slight_smile:

This problem has resurfaced. I am using the solution

sh -c ‘(sleep 90 && echo 204800 > /proc/sys/fs/inotify/max_user_watches)&

and I even checked the file and the value is set. But just in the last few days it no longer works even after reboots, manually setting it etc. something has changed/broken in Roon or Synology. This is no longer working. Has anyone resolved or can help?