No more DSD upsampling since 521/528 Roon releases

Core Machine (Operating system/System info/Roon build number)

  • Windows 10 PC 64 bits
  • Asus MoBo/intel Core i5-2500k CPU/8 Go RAM
  • Roon 1.7 (build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Arris TM722G Cable Modem/Ethernet/Asus RT-N66U/Ethernet/Sonore OpticalModule/Ethernet Fiber/Sonore OpticalRendu/USB/Benchmark DAC3HGC.

Description Of Issue

Before build 521, I could use the Roon sample rate conversion feature at DSD64/96kHz on my DAC. I could see the proper sample rate/word length on my Benchmark LED display and on Roon’s signal path display. Once I updated Roon to 521 build, sample rate displayed on my Benchmark LED display and on Roon’s signal path display is the original sampling rate of the played music track (no more DSD conversion). I created a support ticket 19 days ago, which is still not resolved. I decided to wait for a new Roon build, before pursuing my issue with the Roon support team. Today, I downloaded the latest Roon 528 build and still have the same exact issue.

I made sure I had the latest 2.7 Sonore SonicOrbiter OS. Made sure that my OpticalRendu configuration was correct (DSD Support set @ DoP), but with no resolution of my issue. When I am setting the OpticalRendu configuration, the Benchmark LED is displaying DSD 64 as the sample rate when no music is playing. However, as soon as I start playing music, the Benchmark LED is displaying the track original sample rate (no DSD sampling rate).

Hello @Daniel_Babeux,

We have not seen other reports of Build 521 preventing DSD upsampling from occurring, so we need to determine what is different about your setup that is causing this issue to occur.

Could you provide a screenshot of your DSP Engine Sample Rate Conversion Settings?

-John

Here is what display path is showing with the above DSD settings:

Hello @Daniel_Babeux,

Based on these screenshots, Roon is not configured to upsample content to DSD.

I recommend clicking the “Custom” drop down menu and selecting the DSD option in the drop down. This will upsample all content to the DSD rate of your choice.

-John

Problem solved! Guess I’m getting old :worried:

Thank you for your support!

you will learn something new everyday even if you dont want to…old or older its all the same for everyone :slight_smile: now go enjoy your music :stuck_out_tongue:

That is so true :+1:

Thank you for your wisdom. Yes, music sounds good now!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.