No output from Hifiberry DAC2 HD with RopieeeXL 2022.04

And you’re on ‘regular’ RoPieee or on XL?

I just switched to xl because I listen sometimes to spotify, but I don’t care too much - so what is easier for you…

Ok, I’ll prepare a beta build so you can test.

I’ll ping you here when it is available. You can switch to the beta release channel on the ‘advanced’ tab of RoPieee’s webpage.

fwiw: I’m not that confident that this will fix the issue: it seems kernel related and besides a regular update they didn’t do anything else. So let’s see :wink:

Great - let’s give it a try! :slight_smile:

@Matthias_K

Update is out there.

So:

  • switch to the beta channel
  • configure and reboot
  • wait for the update notification
  • update
  • test

cool - i switched to beta (auto update also on) on my pi3-xl (2022.06.4 (457) [beta] and rebooted it - how long could it take until the notification pops up and where do I get it? Sorry, looks like it was some kind auf auto/without my attention with the old ropieee branch…

You’ll get it in the web interface and it can take up to an hour or so.

It behaves differently then in the past: you’ll get the update notification after the update has already been downloaded and is ready to install.

1 Like

Good news: it worked! :slight_smile:

…but: some strange behaviour: it didn’t worked at the beginning (both Roon and spotify) with “fixed volume”, so I was a bit frustrated and fiddled around with volume settings and switched to “DSP volume” in device setup in roon and it started working, now also “Device volume” and last-not-least even “Fixed volume” now works (also for both services).

Is there something I could do to pinpoint the issue?

(RoPieeeXL 2022.06.4 (0503))

I just pressed the “send feedback” button: 267d08502e393365 just in case this helps.

For now I’m purely interested in Roon.
So to be sure: device volume (not DSP!) works now? So it is not resetting the volume back to zero?

more findings in ec0ec0bf56123f19

It looks like changing volume in “Device” mode breaks it, after doing so the slider goes back to 0 and also “Fixed” is not working anymore (if you switch to it). But you could heal it with “DSP” mode. If you do so (switch to dsp and do whatever you want there), all modes are working again, until you try changing volume in “device” mode again, which reliable breaks it. Just switching to “device” mode with keeping the slider alone to 100 does not break it.

yeah ok. but that means that the original issue is not fixed.

DSP volume means that Roon takes care of everything: there is no interaction with the device mixer.

So we need to wait (again) for Hifiberry to do something about this I’m afraid.

ok - maybe I misunderstood the original issue, but I’m glad that it now works at least for me as a fixed mode user, because it started in “no sound mode”.

If this would have been the case from the beginning, maybe I was missing the workaround (“just start dsp mode to get it running or fixed mode healed”). :slight_smile:

But thank you nevertheless for your help!

Hi Harry

I’ve spotted that RoPieeeXL 2022.11 (0579) has been just released.

Unfortunately, it’s still not working with RPi 4B + DAC2 HD HAT from HifiBerry. You might remember that volume issue. Same behavior as with 2022.04 (as in this thread).

That volume issue should have been fixed upstream by Hifiberry developers, but they never did.

As far as I can understand, the latest RoPieee(XL) 2022.11 is on Linux kernel 5.15.74 …

Apparently, the latest 20221118 HiFiBerry OS release is on kernel 5.15.78.
So, if I’m not wrong, for the first time since I own a RPi+DAC2 HD HAT, their OS is on a newer kernel version than Ropieee’s.

Do you think this kernel upgrade could finally (somehow magically) fix the volume issue of the RPi4+DAC2 HD with Ropieee?

I can do a bit of beta testing, if it may help.

The reason I dare to ask you is that I prefer Ropieee over Hifiberry OS because I can use a (RealTek) WiFi dongle on my RPi to increase network connection stability (also when HiRes files are played by Roon).

Thanking you in advance

Best regards

Mauro

I had a similar problem, and I was able to work round it.

Switch the roon zone to device volume. If the volume is showing as zero - then that’s likely the problem.

Try and chance it to maximum, and them switch roon to dsp volume, and don’t use device volume again!

YMMV!

Also happy to test out if @spockfish thinks the kernel upgrade might have solved the problem. @Mauro_Filippini, have you by any chance tried out the new HiFiBerry OS to ensure the problem doesn’t now appear on their end?

Steve

Hi Steve,

no problem at all on their HiFiBerry OS (20221118). It works as intended, except for the mute/unmute function under Roon. However, the mute/unmute is NOT supported under their OS (so Daniel answered me last May, when I contacted them through online customer support).

In any case, DAC2 HD HAT + RPi4B1.5 has always worked under HiFIBerry OS (also in previous versions).

What attracted my attention after this update is that for the first time (to my best knowledge) HiFiBerry OS is on a Linux kernel (5.15.78) that is newer than RoPieee (5.15.74).

Let’s see

Regards

Mauro

On my config (RPi3+DAC2HD) with RoPieee volume drops to zero (0) if I’m trying to change it after power on, so I configured start volume level at 100 and don’t change it - it’s workaround for me