No playback on NAD c 388 with Blusound MDC

Roon Core Machine

M1 Max Mac running Roon.

Networking Gear & Setup Details

Mac on wifi. NAD on wired connection.

Connected Audio Devices

NAD C 388 with Blusound MDC

Number of Tracks in Library


Description of Issue

I have a NAD C 388 with a wired connection to the Blusound module. This module works with the blues remote streaming tidal. I was able to use Roon to connect to this for a few days of playback. At first it worked without problems. Then a couple of days ago the music would intermittently stop.

From yesterday, music no longer plays on the BluOS module. The device is detected and appears in the audio device section.

Have you tried resetting the C 388 from it’s menu? I have a C 368 and have had to do this more than once.

Perhaps this link may offer some suggestions:

I have updated the NAD with the latest firmware according to the guide. Now the issue is that Roon will stream my local library files from my HD to the NAD, but when I try to play anything from Tidal, it will not play.

Local File playback:

Tidal playback:

Have you rebooted the Roon Core since you updated the NAD firmware?

The core is on my 2021 MacBook Pro. I’ve restarted the computer. Now it played for about 2 songs before encountering the issue again.

It’s not a network issue, I am getting very good speeds, and my NAD is plugged into the ethernet.

Are you running your core and remote on the same computer?

Yes I am. The issue is with Tidal specifically. Local files stream fine.

Hello can I have a support ticket opened for this please? I can’t play tidal from Roon.

This is already in the correct section for support.

Great. Is there some SLA for response or troubleshooting?

Hey @Shon_Mohsin,

Thanks a whole lot for being this patient while we got a chance to reply. We’re grateful for your engagement on the community and for your willingness to sort this out.

Could you please clarify if:

  • Tidal streams to your audio devices outside of Roon?
  • does TIDAL play if you try to play to System Output as a zone (you might need to enable it first in Settings → Audio)?

Thanks :pray:

Hi, thanks for responding. Yes, I can play tidal directly from BluOS for example, or through tidal connect to the BluOS module.

Tidal does not play at all, even with the system output as a zone.

I have also deleted the cache and then re-authorized Tidal according to a thread on Tidal troubleshooting.

Thanks @Shon_Mohsin,

If you check the tier of your TIDAL account, in TIDAL, could you please let us know what it is?

The reason I ask is because the free tier of TIDAL is not supported in Roon :nerd_face:

Hi Beka, I have a HIFI Plus account from tidal.

I appreciate that confirmation :pray:

Two more questions if I may:

  1. If you play to any other zone (than System Output and the NAD) from TIDAL via Roon, does it work?
  2. If you navigate to Settings → Services → TIDAL and lower the streaming quality, does it play any sound?

Finally, would you consider (even just temporarily) changing your Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS?

Hi, answers to your questions:

  1. I only have these two zones. I noticed that when I restart the computer, and then log into tidal, it will play 1 song. After that song finishes, it will not play any more.

  2. Lowering the streaming quality does not change the behavior.

DNS configuration change is quite involved. Can we try troubleshooting something else? Perhaps you can take a system log from roon if it records something?

Hey @Shon_Mohsin,

Thanks for the quick follow up.

Let’s try this first:

  • Stop Roon Server from running
  • Find and open your RoonServer database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server and streaming music from TIDAL

Thanks a bunch :pray:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.