Node Gen 3 + USB Output + SMSL Dac + MQA

Ok so then we know Roon’s handling of MQA isn’t the issue.

When you used Tidal on the Bluesound were you using the Bluesound’s DAC or your SMSL DAC?

I believe I’m passing the Tidal signal unprocessed from the Node to the DAC when I use BluOS. On the SMSL DAC the green light on the faceplate of the device indicates that it’s processing the data. That light is red when the DAC is fed by Roon. So there is some difference in the way the audio stream is being processed by the two systems.

Bob, another potentially silly question. Some of the behavior you are seeing is similar to what others experience with Bluesound devices on WiFi (not the MQA, but the “skipping” type of issues). Are you sure that WiFi is not active on the Node, even though the Ethernet cable is attached? I’m sorry in that I don’t have a Node to see the configuration options, but some devices can be active with both WiFi and their Ethernet ports active.

There’s only three MQA lights I’m aware of:

blue: mqa studio
green: mqa
magenta: OFS

If something other than your SMSL is doing core decoding then the SMSL should show magenta (or whatever light it uses for OFS) since it is only doing the rendering. If your SMSL is doing full MQA decoding (core decoding and rendering) then it will show blue or green. I have no idea what red means (unless it is using that for OFS?).

When core decoding was disabled in Roon and capability was set to decoder and renderer, what color was the LED on the SMSL?

1 Like

When I had core decoding disabled and capability set to decoder and renderer, I had significant stuttering. The display shifted between two icons. Forgive the terrible photography. Here’s the display panel:


I assume the songs were from different albums?

The bottom one looks like the studio indication. I’m assuming the top one is for mqa/green. Either way that is expected when the SMSL is doing both core decoding and rendering.

Have you tried Roon with just the Bluesound?

Not the same symptoms but there are known issues with the node USB

Thank you for posting this “Popping and Crackling” thread. This is exactly my problem.

I’m using a USB connection exclusively between the Node streamer and the DAC. It’s this USB connection that appears to be implicated in the stuttering or crackling that people experience when using Roon and the Node Gen3. The reason why I purchased the Node Gen3 streamer was so that I could use that USB connection. It’s the only way to fully process MQA files on the DAC. So using a coax or SPDIF connection would eliminate the crackling but prevent full unfolding of MQA on the DAC.

My previous workaround was to use an optical cable from the streamer to the DAC and a long USB cable between my laptop and the DAC. If I do this, I’m cutting Roon out of the equation when I use my laptop (I run Roon on a ROCK and not on my laptop).

I will take a long view here–that at some point someone either on the Bluesound side or the Roon side will figure this out and fix it. So I’ll hang onto the streamer and continue to use Roon and just adjust my cabling so it all works satisfactorily. As far as I’m concerned that’s the resolution for me.

Thanks everyone for the information and help. This is a great community.

Hi Bob.

In the settings section under audio of the Bluesound Node, did you turn off the audio clock trim? I have a Bluesound Node 2i connected to a Denafrips Ares II via toslink. They recommend turning off/disabling the audio clock trim when using an external DAC. I hope this helps.

If you are just using the Node as an ethernet to USB roon endpoint, you could get that with different equipment, like a raspberry pi.

If you can return the Bluesound get an RPi (if you can find one & don’t mind flashing SD cards) or iFi Zen Stream. Another option would be to just use the Bluesound’s DAC.

As I understand it, the device setting for the Node within Roon (for usb DAC connection) should be ‘renderer only’ and the core decoder setting should be set to ‘yes’.

Only if you want Roon to do the decode. It is not a requirement. I prefer the Node to do it all.

what happens if you disable replay gain?

I thought the advice I mentioned was from Bluesound, specifically to avoid dropouts and problems when using external DAC and MQA ? Maybe they updated it.

That’s how the thread starter had it set initially (look at his screenshots above) and still experienced the problem.

Bluesound acknowledged a problem with MQA via USB to an outboard DAC. That’s the point I’m making. It may well not be fixed.

I also experience the problem with the bluesound node(130). I own a Naim XS3 and a Fidelity audio power supply with reference pc board. I connected my Denafrips pontus 2 to the Bluesound via USB. Unfortunately random clicks and plops. I run on Qobuz and Roon. Settings as indicated by Roon do not work for me. Does anyone have any suggestions?

Are you having problems with Qobuz? That service works flawlessly for me. My problems are with Tidal. How good is your internet bandwidth? Have you tried making a coax or toslink connection from the Bluesound to the Denafrips? Sorry I can’t be more help.

Hi Bob, thanks for your quick response! Qubuz always works well for me. The internet is via fiber optic and via utp to my bluesound. I have decided to connect an spdif (is on order). Without Roon, so I don’t experience these problems directly via Qubuz!! Special right? I assume that the Roon does not yet have a solution for this problem with the Bluesound Node via USB… Too bad, does not seem very complicated to me.