Not able to access USB storage from NUC ROCK

Following a successful install Roon is not able to see my USB key for the restore backup.
I am now left with the only option to do it via Dropbox although it is not recommended.
I have tried every USB port on the NUC and tried reformatting my USB key but nothing works.
USB key is in exFat, Lexar 128GB works on every other devices.
Bios indicated every port to be working.
Also restarted the NUC between each insertion of the USB key to be sure.
Guessing this might be a bug with the Roon software?

From dropbox fails, so I’m basically screwed.

Don’t you have to mount the drive in Linux? It won’t just see it like windows does.

I guess… how would I do that once ROCK is installed? I’m now facing the same issue now that I want to use a USB as my music storage. It’s never listed. Nothing about mounting a USB drive with ROCK in Roon installation.

I guess my main question is how does someone access USB storage in ROCK?
From the instructions it just says plug it in and access it in the file explorer of Roon.

That answer needs to come from someone who knows ROCK. I can barely use linux, but when I plug in drives they have to be mounted.

External drive should be formatted to exfat, and then accessed via SMB. If you want to restore your database, connect your usb to a normal everyday computer or laptop and, then point roon to it.

See if that works, if it does it might be a bios setting that stopping the usb’s from being read.

Do you have a Windows or Mac PC on the network , can you see the NUC share in File Explorer. You should see something like below …

Mine is a 10i7 NUC with a 4Tb Internal SSD and an external WD Passport 5Tb USB in Windows it looks …

I just plugged the USB drive into one of the USB3 ports and it appeared as shown, I have never removed it since (maybe a thought)

In Roon


Nothing wrong there

Your USB should be formatted exFAT (although NTFS works it could hit a demounting problem.), just a thought the “messy USB name” is provided by ROCK, you cannot rename it

You could try shutting down complete , power lead out , then insert the USB and restart , may do something

@Formula suggestion about restoring from a Windows PC sounds good to me, a SB stick should show up as per my USB drive in File Explorer

Thank you for your help.

My USB key is already correctly formatted to exFAT.
In File Explorer I only see an empty folder under Data>Storage, I don’t see an InternalStorage folder which is weird.


From reading your comments about accessing it via SMB, does it mean my drive should be formatted AND empty before plugging it in? Then move all my music collection over the network?

I had first formatted then copied on Windows my music collection then plugged it in… Could this be the issue?

I will try…

Didnt help, I also tried to add to Internal Storage and nothing to chose from in the Roon interface.
Never would have thought that it would be that complicated to switch my Roon from Windows to a NUC.

Why is your Roon Server restart 7 minutes, 33 seconds behind your RoonOS restart? That latency should be about 5-10 seconds.


I clicked restart manually.

I have also noticed I would be supposed to see some sort of Storage info in the web UI but there is none… starting to feel like Roon restore backup messed up my install. Might try doing a fresh install and see how it works.

This install is driving me crazy I have almost spent my whole week trying to install ROCK on NUC/migrating.

Thanks to all trying to help me, just needed to vent for a sec here :sweat_smile: I feel like this should really not be as complicated for something I’m paying 15$ a month to be honest.

Do you have an internal SSD for music ?

in the web interface , The Roon Database and Settings sections shows your OS SSD with 98% of 79 Gb free that’s fine but there is no internal drive showing . Don’t forget the OS drive cannot be used for audio files no matter how much space is left on it.

This is mine with a 4Tb SSD for content. If you don’t have another internal SSD (for content) then your 2 screenshots are correct. The Bottom Right segment of the web interface should be blank, externally connected drives won’t show here.

If you have an internal drive it should show in both like mine .

You are mentioning a USB external drive for audio files is that “MyBook”, and where is it plugged in currently ?

The only thing that isn’t recommended is restoring directly from the Dropbox shared folder. Download the backup from Dropbox to the local disk first, then restore that

Have you followed the guide for setting up a NUC for ROCK? (Bios settings, etc) -

If you see my comment below I ended up restoring via SMB shared network instead, It worked.

I did yes, more than once.

Interesting, in that case it would make sense that I do not see internal storage as there is only one SSD installed with Roon OS only. The USB storage is just a regular USB stick (Lexar 128GB). It is currently plugged in the back of my NUC.

That makes sense , BUT what doesn’t is why Windows doesn’t see the USB stick in the NUC port , unless as @Geoff_Coupe suggests its a dodgy stick.

The next test I suppose is to try an alternative USB drive or stick to eliminate the “suspect” stick , do you have another drive you can try preferably a different manufacturer ?

You should see in Windows Explorer a folder

Obviously the top Internal Storage won’t be there as you have no internal storage , the USB drive shown here is simply that a exFAT formatted USB drive plugged in. I am pretty sure the drive was formatted under Windows then plugged in.

I didn’t see that clearly stated, but in any case an off-site backup is good to have, and I thought worth clarifying that “Dropbox isn’t recommended” isn’t entirely correct

You’re right, it seems one of my post was deleted. But basically I was able to successfully restore from SMB after failing via USB. But the same problem comes back for music storage.

@Mike_O_Neill i’ll try with a different stick although this one is practically new…
Thanks all for your help

1 Like