Not connecting after successful Install: Ubuntu 16.04/Lenovo YT3-X5F Android Tablet/QNAP TS-251+

Hello Fellow Rooners!

I am a noob, just recently got into the game with the purchase of my QNAP TS-251+ NAS.

So, before I launch into my hard luck story, here is the lowdown:

QNAP: running Raid 1 6TB mirrored Western Digital Red NAS drives, QTS 4.3.3 installed, 8GB RAM. Installed RoonServer QNAP x86 64 2017-02-02.

Lenovo YT3-X50F Android: running Android 6.0.1. Roon Remote 1.3 Android.

Lenovo Thinkpad T-430: running Ubuntu 16.04 LTS 500 GB SSD and 16 GB RAM, with latest software updates as a bridge to my USB DAC. Linux Roon Bridge x86 64.

So, I followed all instructions, created the RoonServer directory on a very fast 128 GB Corsair USB 3 stick formatted to EXT4 connected to the QNAP TS-251+. Installed the bridge on my laptop, then, finally installed remote software on my Lenovo tablet.

Out the park, everything worked! Remote found my QNAP Roon core named “Beyonder”. Selected folders and voila!

However, during file scanning or “analyzing” the bridge output to my laptop bridge was getting drop outs at normal CD resolutions. I figured that the CPU intensive first time “analyzing” process was the culprit. NOTE: my laptop at the time was streaming wirelessly from my QNAP Roon core, I was going to later wire it directly to the router.

The next day, I am waiting and waiting, the remote is searching for the core, I get “Initializing…connecting,…connection failed…or…back to…initializing” The screen info is as follows: Beyonder Linux 4.2.8/“ip address”/Version 1.3 (build 223).

After long waits, I simply removed and reinstalled Roon software on the NAS and the Lenovo tablet, still the same issue, the system is trying to log on to the old install.

So, my questions are as follows?

  1. Can this be a routing issue, setting in QNAP network setup?
  2. Is the QNAP hardware profile I outlined enough sufficient or lacking for CPU/RAM intensive running of ROON?
  3. Should I maybe consider making my laptop my ROON server, in such a scenario could I possibly still use the data on my QNAP NAS as the data centre so to speak?

I do love this software, my trial license is running out on May 8, so it would be great to get it up and running like it should be.



Moving this to “Support” and tagging @support.

Hi @Khalid_Ansari
Have you tried to stop and start the RoonServer on the QNAP again (via AppCenter)?
Regarding CPU power and hardware resources: You can check the resource monitor in the QTS web administration, to get a feeling if your QNAP is already under heavy cpu load.

If you still can’t connect, try to stop RoonServer via the QNAP AppCenter. As you just started with your Roon database set, you could just rename the RoonServer folder (in your RoonServer shared folder) to see if it will work a again with a new database. Then start it again.

There are some other options available for debugging QNAP issues, but if you’d like to evaluate Roon first, without fighting your current issues, you could also use your Lenovo as the core. I am sure, if this is not related to your QNAP’s performance, we can figure out what’s wrong here. :slight_smile:

Hi Chris,

I followed your advice, thankfully the Lenovo tablet remote did recognize the QNAP NAS server directory after a stop/start action. I had to reload all information again. As for the database on the USB 3 Corsair drive, I had wiped it and started from scratch.

I feel that there is a possible wireless issue: perhaps the Lenovo tablet cannot handle the initial “audio analysis” that the Roon software uses for crossfading and gain levels. Still, having switched off “audio analysis” I still get a message telling me that the audio file is loading slowly. Does this mean that I should consider a wired connection to my DAC? Maybe a router problem? My overall local connection hardware not being up to scratch?

Again, love the software, but what is worrying me is that I have not even as yet added my gigantic high resolution library, if the software is having issues with mere MP3s and CD quality FLAC, I am a bit of a bind. :sweat:

Would really love to hear from another community member who has a similar setup and experienced the same problems?

Thanks in advance!

This message might also indicate a network issue. Can you check if there are no firewalls enabled, that might block network traffic. Also check your MTU settings of your QNAP ethernet interfaces. The MTU values should be 1500. Higher values are used when Jumbo Frames/Packets are enabled. You can check this in the network settings of your QNAP.
Are you using managed switches in your network configuration?

The audio analysis is performed by the core (your QNAP). So I’d guess it is unlikely it is a performance issue of your Lenovo


Had a poke around at the network configuration of my QNAP NAS.

MTU is set at 1500. No firewalls, I have a TP-Link TD-W8980 DSL modem/router, no firewall activated on it. IPv4 assignment is static, not automatic. Not really sure about the managed switches? You mean to say that out of the two network adaptors available on the QNAP TS-251+ model, how many I am using? If I am understanding you correctly there are the two network adaptors and I am only using adaptor 2 as it is the only one plugged in, and it is on auto detection.

In addition, the QNAP is plugged into a TP-Link powerline ethernet adaptor, this guy right here: Maybe this extra info might help in a successful diagnosis.

As for your comment about the audio analysis, yes, that was rather a silly observation from me, of course the Lenovo tablet would not be involved in any audio analysis, however, even if I try to surf the web or minimize the ROON remote app on the tablet, audio performance degrades and stutters.

Another thing I noticed is that wireless audio streaming will work fine for a couple of minutes, and when correlated with the actual CPU processing occurring on the NAS it seems rather high, 26% at a minimum and 33% at a max, with about 16% RAM utilization. At the time of running ROON server, I am not running any other applications on my NAS.

Hello Chris!

I did follow all the advice you gave me on your last post, alas, nothing worked, so as the last resort I shifted the core from my QNAP NAS to my Lenovo ThinkPad.

As you may know, I managed to use my Lenovo ThinkPad as my core and output, ROON works quite well in this environment.

So, all is well, HOWEVER, it would have been great to use the QNAP as my core since I assume I could have used its HDMI port as my digital out to my OPPO DAC, which would have been sure bliss, and with the Lenvovo acting as a bridge I would be made in the shade. :slight_smile:

Sooo, my question is: can I somehow install the bridge software on the QNAP NAS? I am loathe to try to tinker with switching my core again to the QNAP.



There is no dedicated bridge install. But you can install the RoonServer package again. Leave it as it is and do NOT set it up as a core. The audio bridge is also running when launching RoonServer, even though RoonServer is not configured. Then try connecting the DAC to your QNAP and see if you can select it in the audio settings of your Roon remote (which is still connected to your Lenovo Roon Core).

Hmmm, OK, Thanks Chris, will give this a whirl.

Chris, been tinkering away all morning.

Here is a brief summary, this may help you troubleshoot for others down the line:

  1. Installed ROON server on the QNAP again, did not set it as core. ROON remote recognized the QNAP as a network device, all was good and I was quite pleased with life! I did have to create a RoonServer file on the QNAP, otherwise core on QNAP was simply not launching.

  2. Shut down ROON remote as my tablet needed to recharge. Went away for a bit. Returned to find that my ROON remote could not initialize with the ROON core on my Lenovo ThinkPad. I checked the status, I was seeing the two cores: ThinkPad and QNAP. So, since I remembered your advice from before, shut off the QNAP ROON core and my remote did finally connect to the ThinkPad.

  3. However, it started to have problems again, failure to initialize, to connect. So, in a pique, I decided to go ahead and go the full server install on the QNAP, which, to my great surprise, worked…for a while. I was even able to use either HDMI or USB out from the QNAP to my OPPO, which was just a stunning amount of choice!

  4. Switched back to the Lenovo ThinkPad as my core, worked again. and was OK for a few days, until recently I noticed that I was getting system errors on my ThinkPad from Ubuntu 16.04. I have taken a screen shot of the system error. It is RoonServer related. As soon as I get the system error, I do a reboot and I can connect to the Core via the Roon remote installed on my tablet.

Again, my apologies for the late reply, but instead of doing a bit by bit update, I thought I would see if I can cover all bases.

Thanks again!