NOT READY: Roon Arc Is Not Able to Connect to My Roon Core

Roon Core Machine

HP Elite x2 1013 G3, Windows 11 Pro, 64-bit operating system, x64-based processor

Networking Gear & Setup Details

Gateway/Technicolor CGM4331COM, I used both WiFi & ethernet, I use a VPN for work

Connected Audio Devices

Bluesound Pulse Flex 1

Number of Tracks in Library

1,000 tracks

Description of Issue

Well, my problem is that my phone with Arc isn’t connecting to my laptop’s Roon Core and states ‘not ready.’ I’m unsure what that actually means since I already tried a few different tactics to try to connect them. I tried to manually to connect them by adding a port forward on to my router using router’s app. To no avail. Below is a copy of my diagnostics data that pops up when failing to connect or not ready.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“XX.X.XX.XXX”,“router_external_ip”:“XX.X.XX.XXX”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“XXX.XXX.X.X”,“found_upnp”:true}

@HEC Hello and welcome — i had same problem this am I simply closed down ROON restarted it and ARC connected to my ROON Core—you might have have to shut down your PC/laptop and restart it also— I sometimes have to do that with new versions of ROON/Audirvāna —hope this helps —- haven’t tried it on my laptop yet but works great on my iPhone 13 and when connected to my vehicle’s alpine sound system apple play works and sounds so much better than SiriusXM ! My computer and iOS is new Mac mini 2022 with M1 chip.
For anyone else/SUPPORT I was playing a Townes Van Zandt album in the car but when i tried to play something else I believe from TIDAL nothing else played and the message was “couldn’t connect to CORE—anyway to correct this—- obviously CORE wouldn’t be available miles from my home!
Otherwise will keep fiddling with this ARC—I am so glad a I have lifetime subscription and what a great feature this is KUDDOS to ROON engineers if it works

1 Like

A post was split to a new topic: ARC Not Ready ROCK

Thank you for that, Robert. I will try that now and see if that works. Hopefully a rep from Roon helps me.

Hi @HEC,

The team wants to extend a thank you for your patience while we’ve worked through the queue of port forwarding-related issues on Community.

There’s a 504 timeout indicated in your port forwarding diagnostics - the most common culprit in that situation is a second router in your setup applying an additional layer of network address translation (NAT) that prevents the Core from communicating upstream to the internet.

Would you mind confirming the following?

  1. Who is your internet service provider?
  2. Is there an additional router in your setup other than the Technicolor modem/router combination? If so, you’ll need to place the Technicolor in Bridge mode.
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. The VPN might also be responsible for blocking the port forward, as it will set a different external IP address. That won’t necessarily be an issue, but ARC doesn’t technically support VPN use. However, many users in the #tinkering section have configured a port forwarding alternative using a VPN.

I’m surprised that you haven’t received more questions about this. There must be millions of XFinity users like me out there whose modems are not set to Bridge mode by default. You did provide the information I needed and the links to reset mine, but it took a bit of looking around. Thanks for that, but you might emphasize it a bit more. Also, had to update Roon remotes on my iPads from the app store after updating the core to 2.0 first. Did not happen that way in previous 1.x updates. Did get everything working eventually and I am very pleased.

Hi Connor,

• Cox Communications
• There isn’t
• I don’t
• I did have a VPN and deleted that from my computer.

After deleting the VPN, I’m still having issues to access.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.