Not ready - Roon ARC was unable to securely access your Roon Core: 2 routers

Roon Core 2.0 (build 1169) on NUC-I5

I have 2 routers: Asus RT-AX88U behind a T-Link using DD-WRT.
NUC is connected to Asus (

I got ARC to connect when initially setting up the NUC so know it works with my ISP (NextLight), but at that time it was on ethernet from the T-Link router ( I stopped using ARC for a few months as it wasn’t quite stable enough yet, but I have a road trip coming up and would like to try it again.

I’ve: restarted my Core, turned off/on UPnP on both routers, manually setup port forwarding on both (Port is now 55002), rebooted everything, turned off/on firewalls, and read/tried everything I’ve found in the community…

Help, please

Diagnostics data:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

Made some changes I don’t remember and now I get this:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: ConnectFailure”}

WAN IP on 1st router is indeed the in the diagnostics screen

Possibly UPnP still running in addition to your manual rules, or an error in the manual rules creating a conflict

I would assume PPnP could remain on with manual port forwarding, but…
I’ve added screenshots of my port forwarding to my original post

Don’t assume. Yes, one might think so. In reality, not every router deals well with it and there have been numerous cases on the forum where this was the problem.


You normally need only TCP forwarded, not BOTH.
Shouldn’t “Source Net” have an entry? (I have no experience with DD-WRT)

I can’t see if UPnP is on.
Also check the Port Range Forwarding tab to ensure that there is no conflicting rule there

Check that the Roon ARC settings in the main Roon app show that it’s using the 55002 port.
Try clicking Reset in the Roon ARC settings in the main Roon app, sometimes it seems to help.

I missed this originally. With 2 routers you probably need two daisy-chained forwarding rules. One on the T-Link forwarding the external IP:port to the Asus, and on the Asus to forward it on to the Core. And the 2 rules must not conflict somehow.

Try something like this:

A ConflictInMappingEntry error also occurred here, also with 2 routers, and was resolved by daisy-chaining the rules on the 2 routers:

Thanks for all the advice! I did try disabling UPnP on both last night to no avail.
I’ll check out and try the other suggestions later today and report what works or doesn’t.

1 Like

Hello @Bill_Juvonen

It could be a red herring, but I updated my Asus router (GT-AX6000) firmware l last week to version Since the update , UPnP / automatic configuration of ARC seems to fail. It worked fine, reliably and consistently, before. It may or may not be related.

I have not bothered to troubleshoot this systematically, other than a router reboot and reboot of the Roon Server (to no avail). No reason, as I normally use ARC, if at all, with a ‘0’ port configuration and VPN, which is unaffected. And I just checked that opening and forwarding a specific port also still works fine as a fall back.


After spending several hours yesterday trying all the various things suggested, to no avail, I ended up hooking my NUC (Core) directly into the TP-Link router, bypassing the Asus, and ARC connected without issue.

Today I tried with only the Asus and struggled to get a good connection. I ended up disabling all firewalls and antivirus on the computer and the router and rebooting everything and… Success!

The router settings at that time had UPnP on and Port Forwarding off (I never did get it to work with UPnP off and forwarding on). I then started trying different combinations and re-enabling everything one at a time, with varying success.

** After many, many reboots after making changes, I discovered that after nearly every reboot of the router, ARC would fail to start (even if no changes were made on the router). I needed to also shut down Roon and restart it to see what really worked and what didn’t (just Roon, not the NUC). Often it would start up successfully after restart even though it showed it failed prior. I’m thinking a lot of the things I tried yesterday would’ve worked just fine had I known that in advance.

I haven’t tried adding the second router back in… I may not. I put it in initially to try to isolate my IoT devices and cameras but found having two networks too cumbersome and I have strong passwords in place, so I’m not gonna lose any sleep… actually, I’ll lose less.


That’s another way instead of daisy-chaining two rules. If it works for your ISP, it’s IMHO the better option if there are no specific requirements for two routers (I get the isolation attempt). Seems to me that half of the ARC issues are caused by such weird two router setups that their users often don’t actually understand in detail. (The other half by CG-NAT and similar that’s not providing routeable IP addresses, and a small rest by other minor issues like wrong rules or no UPnP enabled)

Dunno about the issue after router restart, but be aware that it can take many minutes after a restart of the router until it has established a connection to the ISP. In that time, nothing that needs internet will work. Make sure to wait long enough before drawing conclusions.

If it’s really not working after router reboot, might be an issue with the router and/or ISP. I never experienced that, but on the other hand I basically never reboot my router, so who knows :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.