NTFS USB drive not seen

It has now become a “known issue” in support. A lot of users experiencing same issue. I’m assuming it needs to be taken care of in another update. My issue is HD attached to NucleusPlus not being recognized as a number of others are experiencing

Have you tried @Wes’s recommendation of disconnecting/reconnecting the USB drive and seeing if the Nucleus recognizes it? If this does not work, then try disconnecting the USB drive, rebooting your Nucleus, and then reconnect the USB drive.

Have done it all, more than once. This started right after 1148 update as with many other users. Roon has acknowledged this issue and is looking into it.

1 Like

Ok, I found a few cases and the problem is that NTFS drives must be ejected properly from windows before they can be placed on Nucleus.

There may be a workaround for me to try, but it’s a scary one.

Can you try this? You’ll need to plug it into a Windows machine, and then eject the drive properly before attaching it to the Nucleus.

1 Like

Been there done that
It has been connected to NucleusPlus since inception and worked fine until 1148 update

I think you are confusing Roon 1148 vs Roon OS 254.

Roon 1148 has nothing to do with NTFS.

Roon OS 254 changed to a much more stable NTFS driver, but it’s pickier about improperly ejected drives (part of the stability effort). I had 2 people having similar issues plug the drive into Windows, run CHKDSK on Windows, and then eject the drive. When they plugged it into a Roon OS machine (1 was ROCK, 1 was Nucleus), it showed up.

I asked your N+ for logs, but I can’t see the exact issue because the drive is disconnected. You are however having some SMB issues with your NAS (it seems to be unreachable from the Nucleus+).

I need you either connect the drive or wait until I have another report of a similar issue that isn’t resolved by chkdsk/eject. Either solution works for me.
Until this drive shows up, or another user has this same issue

I did what another Roon tech suggested. Disconnecting it from NucleusPlus put it on my win10, mapped it and was going to connect from there. I will eject as you ask and put it back on NucleusPlus within the hour.
My NAS connection is seen in Roon storage which I have been using

ok thanks

here is the error in Linux kernel log:

ntfs3: sdb2: volume is dirty and "force" flag is not set!

This tells me you have the same situation as the others. This was on your 8TB Seagate, I’ assuming the same as the one from the screen above.

The other Roon tech did not have the information we have now. We gathered it from you and others reporting the situation.

1 Like

Yes sir
Never had issue until last update
Will there be an update to correct this?

1 Like

Yah, the old driver was known in some cases to corrupt the drive completely, so we updated the driver. The new driver is less tolerant of error situations.

We aren’t fans of NTFS on Linux at all because of all this mess. exFAT is far less troublesome… but you have what you have and it’s painful to convert.

Can I now stop pulling my hair out now, to which I have none anyway, and wait for your solution?

You can, but it’d still be nice to be 100% you don’t have another issue too. I’m not 100% sure the fix (beyond “always eject”) will be coming soon. There may not be a good NTFS solution here without going to the unsafe driver. Let me investigate.

Right now, you are using your Windows box as a SMB share?

just got it again

[317440.560437] ntfs3: sdb2: volume is dirty and "force" flag is not set!

I’m not using SMB share, just the network path, any external storage on the Nucleus is not recognized

The Seagate is not visible anyway so SMB would not be recognized. Do you think I should just get another Seagate 8TB HD and format it differently?

Don’t understand what this[317440.560437] ntfs3: sdb2: volume is dirty and “force” flag is not set! means at all
This is error message when I try to map. SEAGATE HAS BEEN RECONNECTED TO NUCLEUSPLUS

Sorry, I should not used the word “SMB Share” – SMB Share just means “network share”.

You can ignore my message about that error, it just shows the problem is related to this eject/dirty thing.

That would definitely fix the issue. I can’t see how much music you have on the 8TB Seagate, it might be possible to copy to the 4+GB you have free on the other 2 drives.

I have a bit over 4TBs, Should I go with a new Seagate would you recommend formatting exFAT? I don’t know if that’s possible but if so?
I ordered the same one, should have it Wednesday, before I copy from old one I’m going to connect it to Nucleus plus and check to see if I can map it and include it in my Roon storage. I’ll let you know.

Yes, we always recommend exFAT for external drives because that format has the least number of issues cross platform

1 Like

I also lost the use of one of my external NTFS USB drives on my Nucleus +. Running a repair scan of the drive on my PC solved the issue.

I had a problem when I upgraded, it was initially formatted exFAT in Windows so finally I reformatted the drive in Windows on NTFS , then put it into my NUC/RCOK and loaded files via ROCK.

I am always careful to unmount the drive before removing from Windows.

Its been running fine for 4 days now and numerous Restarts