NUC 8i3BEH borked by latest bios revision 79

A word of warning to anyone using the NUC 8 devices…

Today I installed bios version 79 dated 24th April. It left my NUC unable to boot into Windows and the bios in a partially upgraded state.

I was able to resurrect it by using Windows boot repair, however the firmware device in Windows Device Manager is showing version 79 but has the yellow exclamation mark. The bios version show when you hit F2 at boot time is still 78.

All in all a bit of a mess!

I installed this BIOS version yesterday, and I had no issues at all (Roon ROCK, NUC8i5BEH).
May be an issue with Windows installer?..

Yes possibly. I downloaded the native bios installer and tried that via F7 to see if it would tidy things up but unfortunately it didn’t help.

I’m glad your update went ok though, perhaps it was just me…

Play it safe. Why update the BIOS? If it works upon initial OS install, leave it alone. What do you hope to accomplish? Update fever – that has been exacerbated in the iOS and Android spheres – is overblown.


1 Like

Doesn’t seem that safe to skip security updates. Have never had an issue before so had no reason to be overly cautious. All fixed now anyway.

Intel Nuc 8i7BEH
died from the Bios update. irreparable…

Sorry to hear that. Is the issue with the BIOS/device itself, or is it the OS not booting post-update ?

Only the bios is corrupted, it restarts every time. It cannot be updated again, there is no function F7, F9 to update the bios.

look here…

Have you tried the Power Button BIOS Recovery?

In the unlikely event that a BIOS update is interrupted, it’s possible the BIOS may be left in an unusable state. Please follow the instructions and/or watch the video below.

WARNING: This process is intended to be performed by a trained technician.

  1. Download the Recovery BIOS ( .bio ) file. Example:Download the Recovery BIOS file
  2. Copy the recovery file (*.bio) to a USB device.
  3. Plug the device into a USB port of the target computer when it’s turned OFF.
  4. Press and hold the power button down for 3 seconds, then release it. The Power Button menu appears.Power Button Menu appears
  5. Press F4 to start the BIOS recovery.
  6. Wait 2-5 minutes for the recovery process to complete.Wait for the update to complete
  7. The computer will either turn off when the recovery process is complete, or it will prompt you to turn it off.

There is also a BIOS Recovery Security Jumper inside the case as well, see here…

Yes, I tried all INTEL recommendations. I do not display anything except the Intel NUC logo. there is no F’'x ‘’ function as soon as the logo is displayed it resets itself over and over again …

The Security Jumper method does not require any Fx keys. Just open the case, flip the jumper and power on with the .BIO file on an attached USB stick.

I did so, no effect, start 5 sec and reset … I turn on with a 1-2 2-3 jumper and no jumper. with usb and bio file. I hold the 3 sec button, it changes from blue to orange … and it resets itself … I’ve been sitting on this problem since Friday

1 Like

Not good at all :frowning:

I assume you were using the v78 .BIO file and not v79 ?

sure my friend, -(

behaves as if the bios was only partially loading, then reset.

Completely Agree. Unless there is a needed fix for an issue I am having or a new option that I need (like updated CPU support), I leave a functioning BIOS well enough alone.

IMHO, Roon’s ROCK instructions really should have the caveat that BIOS updating is optional, and, that if you choose to proceed you might brick your PC.

1 Like

Whilst it’s obviously great to get expert opinion on my updating strategy; I am fully aware off the risks.

Really this was intended more as a public service announcement on the specific issues I had with this update. Perhaps to forewarn others if possible.

1 Like

It seems that INTEL has withdrawn BIOS version 0079: it is no longer available for download.

1 Like