NUC failed to reboot [Solved - NUC Intel RMA]

Core Machine (Operating system/System info/Roon build number)
These are the parts I am using all bought from Amazon:

  • NUC8i7BEH
  • Crucial 16GB Kit (8GBx2) DDR4 2400 MT/S (PC4-19200) SR x8 SODIMM 260-Pin Memory - CT2K8G4SFS824A
  • Transcend 512GB Nvme PCIe Gen3 X4 MTE110S M.2 SSD Solid State Drive TS512GMTE110S

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Hi - the NUC I built a few months back no longer works. I requested a system reboot via the web interface, and it never came back online.

When I connected the NUC to a monitor to see what’s going on, I can get to the BIOS via F2. What I can’t tell is if the SSD is being recognized as I can’t see it to put in Boot Order.

Is there a way to tell when I do F2 to actually see if the 512GB M.2 SSD is there and being recognized by the NUC?

I did unscrew the Intel NUC and reseated the m.2 SSD, but it didn’t make a difference (I can see that the 16GB of RAM is recognized fine).

Here is a screenshot with the error message when I attempted to do a Roon Recovery as noted in another post with a USB stick (it can’t find any disks to install on which pointed me to the m.2 SSD as the potential culprit):

I’m hoping my m.2 SSD is still okay … I just don’t know how to confirm that and how to get it to show in the Boot Order.

Thanks for any help! I miss using Roon!

Hi @timmo,

I believe this is the issue here, please see our ROCK: Getting Started:

The drive must be SATA or NVME. We’ve seen some reports that other types of drives like the Samsung mzhpv128hdgm (M.2 slot with PCIe x4 lanes) do not work.

It sounds like your M.2 SSD falls under this category, and if so it is an unsupported SSD type.

Hi Noris - thanks for the response back. Can you please clarify your response? I’m confused as I bought the suggested M.2 SSD as noted in that ROCK guide (1st pic) which I followed when I built the NUC back in March (and has been work perfectly since then until recently when I submitted a reboot command), but I got the 512gb version instead of the 128gb version (2nd pic below). It’s the same manufacturer/type on Amazon with 3 different sized options, and I got the 512gb version (3rd pic below):

Apologies if I’m missing something here. Thanks.

Hi @timmo,

Thanks for confirming the M.2 in use, this doesn’t sound like the one with known issues, apologies for the mix-up.

As for the issue itself, have you tried using the SSD anywhere else like on another PC to verify that it is still intact?

Are you able to install any other OS on the NUC, such as Ubuntu with the current M.2 SSD? Does that work properly?

Hi Noris - great, thanks for confirming the M.2 SSD I’m using is the right one. I’m not very technical, and I don’t have another PC that would support M.2 SSD, so I don’t know how to tell if it’s still good or not anymore (it is only 3 months old from when I bought it). I reseated the M.2 SSD again in the NUC and still not seeing it listed in the BIOS as follows under SATA or PCI:

Am I correct to assume that if it was a working M.2 SSD, I should see it listed under PCI? I see “M.2 Slot” checkmarked, but I don’t see the device itself listed if that’s where it should show it (unless it should show under SATA?). This is where I’m lost in troubleshooting this.

If the above assumption is correct, my thoughts are: 1) buy a device that can read the M.2 SSD to confirm if still good or not (any recommendations?), or 2) buy the recommended 128gb M.2 SSD for $29 and see if I seat that in the NUC if it then gets recognized.

Option 1 will probably cost about the same as #2, so that’s why I’m thinking I should just buy another M.2 SSD. Before I do that, just want to make sure I’m looking at all this correctly in the BIOS and not missing a step somewhere to confirm its status.

Thanks again for the help!

Hi @timmo,

If the price is the same, I would opt for the other SSD in case this one has gone bad. A free test in the meantime would be the one I mentioned before:

If you want to try installing Ubuntu and see if that works, it could tell you if it’s the SSD.

Thanks Noris - I went ahead and bought the 128gb SSD and the same thing happened where the NUC BIOS is not seeing the M.2 SSD, so I’m not sure if it’s a NUC hardware issue with that M.2 SSD slot. I can try installing Ubuntu next, but I guess I’m confused as to why the NUC would not show the M.2 SSD in the BIOS if it’s installed (without an OS being present). Does having an OS make a difference in recognizing the M.2 SSD? I’ll need to research how to install Ubuntu on a NUC.

Hi @timmo,

Are you still within your return window from Amazon? You might want to swap it out if so, sounds like it could be an issue with the NUC itself.

Hi Noris - I’ve been working with Intel Support the past few days and they are going to RMA my unit since all troubleshooting steps have failed to recognize either of the two M.2 SSDs I have (and I”ll try to return the M.2 SSD I just bought to prove this out). Based on my experience with all of this, I don’t think an OS is needed to be present in order to prove recognition of the M.2 SSD - the BIOS itself should show it if recognized regardless of OS status. Fingers crossed that the new NUC will give me years of trouble free enjoyment of Roon!

1 Like

Hi @timmo,

Swapping the unit out sounds like the next logical step, so hopefully once you swap it out you will have the trouble free enjoyment :slight_smile: . Do let us know how it goes!

Hi @noris - all is finally good now! The RMA came back and I hooked it up today and it instantly recognized my M.2 SSD after setting up the NUC properly to read it. It was a hardware failure with my original NUC unit (glad to get it replaced). I was happy to see that I had very little reconfiguration to do after installing everything…it just worked using the original M.2 SSD! Nice to have Roon back after many many weeks without it.


Hi @timmo,

That’s fantastic news, glad to hear that the RMA’d NUC is up and running!
If you run into any other Roon issues, just let us know and we’d be happy to take a look!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.