NUC Installing Issue

I have a problem installing Roon on my NUC7i3bnk.

NUC bios version : 0082(latest)
Boot setting : Legacy(checked), UEFI(unchecked), Network Boot(unchecked)
M.2 Slot SSD installed : Samsung 960 EVO 250GB

I have flashed image to usb stick(16GB)
(I can’t select file system option when I use Rufus.)

Now, The roon install image on usb stick has FAT file system. (Not FAT32)

I have tried to install Roon on my NUC. It can’t boot by USB image.

WARN: No MBR magic, treating disk as raw booting

It displays this messages.

I have already tried this process many times, but the same error message appears.

How can I fix this?

try maybe with etcher software? maybe your bios is not set to boot USB drive first?

I tried to install it with etcher. but the error message was same.

I tried to boot other OS usb image(Windows, Linux) It has no problem.

try and re-download the ROCK image maybe

I already re-download and re-flashing ROCK image 5~6 times but it don’t fixed.

have you tried to boot that USB from another intel PC and see if it boots (not installs) but that would prove the image is OK and usb is OK

what about another USB port on the NUC?

Another PC appears same error.

I also tried another USB port to install but it can’t fix.

I think the ROCK image on server maybe corrupted.

possible…moving this to #support and tagging them @support for you

1 Like

Hi @Tyhkoon,

Welcome to the forum! Have you tried using a different USB to perform the ROCK install?

If not, I would try to use another USB drive to see if it has the same behavior or if there is an issue with this USB stick.

I tried to install using two usb stick. (16GB, 32GB)

It has the same behavior.

Hi @Tyhkoon,

Can you please let me know if these settings help?

1 Like

I read this post and thought there might be a problem with the m.2 SSD.

This SSD is not brand new that used PS4 with external enclosure.

I installed linux OS(Ubuntu) to create new MBR partition and initialize old partition.

Then, I tried to install ROCK on my NUC again.

Now, I success to install ROCK on my NUC.

Thanks for your help @noris, @wizardofoz.


Hi @Tyhkoon,

Thanks for letting us know that wiping the drive resolved the issue for you!
If you run into any other issues, just let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.