NUC Roon core not recognized

I have roon installed on a NUC with a 10th generation intel I7. Everything has worked well until just now. I came back from 5 weeks away from home and my desktop windows pc cannot find the roon core. In fact none of my devices can find the roon core. The ethernet connection to the core is working fine and I have restarted the NUC multiple times to no avail. I can see all the ROC files from my windows explorer. Not sure what happened. Any ideas?

I have gone into the IP address (see file) and it says it is not running. I keep trying to restart and it will say it has been restarted but the page continues to show that it is not running

@Gary_Cardinale, Roon released a Production version, Build 1324, that resulted in a number of issues, so many that it was pulled and Build 1311 remains the current Production release (and available on Roon’s download site).

I don’t own a NUC or Nucleus so I am not the best to advise here, but your NUC may have been updated automatically to 1324 and now won’t run properly. Is it possible to reinstall 1311 on your NUC and load your most recent backup to see if this corrects your problem?

1 Like

The roon core has 1311. Here is a picture.

Everything looks ok but it keeps searching for my roon server. In the several years I have had the NUC with Roon installed, this has never happened. I cannot get into Roon as it keeps searching for the server.

Try reinstalling the Roon Operating System using the Reinstall button on the Web Administration page. That will also reinstall Roon Server (but won’t wipe out your database and settings).

If that doesn’t help, then I suspect that there’s an issue with your network.


Robert, I have done that and then also restarted the server and nada. Here is what my router says. It is the last item on the list. Not sure why it is not doing anything.

Just curious… How does one actually get some assistance from formal Roon support? It looks like the only way is through this community but no one from support has actually contacted me regarding this issue? I thought that sending this to support would elicit some response but no such luck.

1 Like

Patiently is sadly the answer Gary.

@Robert_F and @Geoff_Coupe are unpaid community moderators and do not work for Roon and yet try and help regardless.

It can take sometimes take a week for @support to pick up open tickets as they work through the backlog that they have.

1 Like

Hi @Gary_Cardinale

Just another fellow Roon user.

I feel your frustration on this one.

I usually run Rock myself, but for the past few weeks have been running Roon Server on Windows so I can rip CDs how I want.

Yesterday I put my Rock SSD back in my machine and had the same trouble you are experiencing. Once the server part was running (almost) my whole library started to rescan grinding it to a crawl.

I also tried reinstalling Rock from scratch but it did the same.

I did find things went a little smoother if I unplugged my USB storage device and allowed Rock/Roon to only scan my Tidal library. Once that was done I added my USB storage and it scanned as normal.

I cannot explain why of what caused it. It remains fairly unstable for a while after the rescans, but I couldn’t get Arc to work. I decided to revert back to Windows and Roon Server.

Not that you should have to go down the route of Windows and Roon Server, do you have the capacity to give this a try on another machine to see if it works?


Note: my Rock was on 1311 too

1 Like

Thanks Michael, I appreciate the moderators but they can only do so much. I guess I will have to be patient. It is frustrating because I did not do anything to change configuration; all I did was disappear for a few weeks and when I came back Roon does not work. Gary

1 Like

I get that Gary, and frustrating is what it is with the small team support team Roon maintain.

Menzies, I have run Rock on my Intel NUC for several years with hardly any issues. And the several times that it did not connect, I just rebooted the NUC and everything was fixed. This time is different. My router shows that Rock is there and my status page shows everything is working although Roon server software shows a green OK and running for 0 minutes and 0 seconds which is odd. I have not changed anything to my router configuration. I really do not want to mess setting Roon up in another location like my PC. It used to be there until I purchased my NUC. Thanks. Gary

I sincerely do understand your frustration.

I was purely expressing how I resolved the issue for myself.

Until Roon @support can help you have no Roon, correct.

Maybe setting up another machine, if you previously had it on a PC is a work around until Roon can look at your logs.


Your call

@Gary_Cardinale, just a quick question on your NUC. Your Roon database in the screenshot you posted shows your Roon database size as practically 0 GB:

What is the size of one of your Roon backups of the database? It appears your music library is only about 92 GB. I would expect the database would be in the ~2 GB range (I have a 212 GB music library but my history goes back 4 years).

Robert, Looks like the backup is 3.5 Gigs. Last modified on 10/13. I have no idea why it shows that 100% is available. I have a second SSD on my Rock which stores my own music. That shows 20% of 492 gigs used.

Yes you are correct. Roon is dead. I might as well turn off my NUC. I can wait until their help experts can respond before I try a completely different setup. I appreciate your suggestions.

I would hope Roon would round that up to 1% utilized, but not sure. Have you backed up lately and reset the dattabase? Again not sure that resetting the database would help here. I saw the music storage was 20% used but still wondering why the database is showing 0% used.

Can you confirm where your Roon Backups are stored?

I cannot even get into Roon. It just keeps searching per this screen.

What if you type the Core’s IP address, in a web browser? How were you able to post screenshots previously? Is the NUC Core now not responding? I also am wondering if you are starting to see a drive failure on the OS/database drive on your NUC.

@Gary_Cardinale, another suggestion to try may be to remove your music storage SSD, allow Tidal or Qobuz (if used) to finish rescanning, then add back the music storage SSD. This worked for another user.