NUC won't start after update

After I installed the latest update, my nuc (NUC5I7RYB) refuses to start up. It doesnt even post. There is no signal from the HDMI port so I cannot restore as suggested in your solution. I tried disconnecting the SSD to no avail. It worked perfectly until I updated to the latest version.


Roon @support will be along to help idc (although it is the weekend so may not be as quick as usual). In the meantime, does this Intel link help? Is your led lit? Long press > 5secs if so.

I have tried the link. The led is on constant for about 40 seconds the turns off for a few seconds and then on again for 40 seconds. This continues. I have long pressed the power button for 5 seconds which results in the nuc powers off again. I tried long pressing with a usb attached with the latest bios in hope of restoring the bios. No luck there either.

Just to confirm, have you tried multiple HDMI cables / inputs?

Is the NUC connected directly to the TV / monitor or are you using a receiver?

Sorry for the late answer. No I haven’t tried other hdmi cables. The one I have has only been used once, when I installed Rock on the NUC. So I am pretty sure the cable is not the problem. The blue led cycle I described earlier also indicates the problem doesn’t seem to be the hdmi cable. I tried hooking up the NUC directly to my 4K tv and also through the receiver.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.