Nucleus+ and Qobuz issue

Hello Team,

I hope you are all keeping well and safe in these difficult times? I wonder if you can help me please?

I am based in the UK and bought a Nucleus+ (Rev A) a few years back. I have a lifetime Roon membership. My music is on an internal 4T SSD. I have about 20k tracks, virtually all ripped from my CDs via iTunes and converted to wav files before importing to Roon. I use an iPad as the Roon client. I used to have the Nucleus+ connected via ethernet to a old Edimax wifi bridge (BR-6428nS V4). Also connected to the bridge via ethernet was my Devialet Expert Pro. My internet router is not in the same room as my hifi hence the use of the wifi bridge. I only turn on the Nucleus+ when I want to play music and turn it off (short press of power button) when I’ve finished listening. Everything was working fine for ages.

I recently replaced the edimax wifi bridge with a Netgear R7000 router operating in wifi bridge mode. I also added an English Electric 8Switch ethernet hub/switch connected to the R7000 and now have the Nucleus+ and Devialet connected to the 8Switch. I also upgraded Roon to version 1.8.

Friday 12th March
I can access the Nucleus+ from my iPad and stream my local music fine no problems. However although I can browse Qobuz content and select an album (I see the track listings) if I attempt to play it the play bar just shows the sweep of a moving blue slider and nothing plays. I can access Qobuz and play albums via the Qobuz app on my iPhone and iPad over the home wifi. Power cycling the Nucleus+ and the R7000 resulted in the situation worsening with no Qobuz content being shown (except playlists - which were empty).

Logging in and out of Qobuz via the Nucleus+ made no difference. More power cycling made no difference. Reinstalling the OS from the web admin gui (version 1.0 build 227) appeared to fix the problem and I could access and stream music via Qobuz.

Saturday 13th March
The following day I powered up the Nucleus+ and was back to square one: Qobuz content visible but not playing. I tried restarting the Roon Server (version 1.8 build 764). This took me back to no Qobuz content at all. Reinstalling the OS again fixes things.

Sunday 14th March
Powered up the R7000 wifi bridge, waited until it was fully active and then turned the Nucleus+ on. Same problem: can see Qobuz content but cannot play any. Changed the Nucleus+ to have a static IP address and set the DNS to 8.8.4.4 (I’d seen a few posts on the community site that suggested changing to the Google DNS can sometimes help). It didn’t help. Tried reinstalling the OS again but this time it did not fix the problem. So I can only view Qobuz content but not play it. I can stream my own content from the SSD.

Monday 15th March
Power up R7000 then Nucleus+. Open iPad Roon app and once it connects there is a button at the bottom of the screen asking me to “Select an audio zone”. Never seen that before? After a minute the button goes away and the Devialet is found. Can see Qobuz content but cannot play.

Remove the 8Switch from the network and connected the Nucleus+ and Devialet directly to the R7000 via ethernet. Restart R7000 and Nucleus+. No change, still can’t stream Qobuz albums. Removed the R7000 and replaced it with the old edimax bridge. This appears to have fixed the problem. I have no idea why? The edimax bridge only supports 10/100Mbit ethernet ports and 2.4Ghz wifi. The R7000 supports 10/100/1000Mbit ethernet ports and was using 5Ghz wifi - could this part of the problem?

Attached the 8Switch to the edimax bridge and connected the Nucleus+ and Devialet to the 8Switch. Everything still works fine but there is a tiny delay in the Qobuz album starting to stream.

Tuesday 16th March
Reconfigured the R7000 to use the 2.4Ghz wifi rather the 5Ghz band and tested the setup again. Can’t stream Qobuz albums. Moved the connection back to the Edimax bridge and everything works fine.

I realise you would rethink that this is clearly a problem with R7000 (which it may be) as removing it and replacing with Edimax fixes the problem. However the R7000 is clearly passing network traffic as I can control the Core from my iPad app. If I asked Netgear for help with this surely they would suggest I have an Roon/Qobuz app problem as, in some instances, reinstalling the Core fixed the problem (albeit temporarily).

I wanted to replace the Edimax as it is very old and have now spent £100 on a Netgear that R7000 may not be doing the job. How can I be certain that buying a different wifi bridge will work?

Is there any help you can give me with this problem please? Specifically, when I click to play a Qobuz album what is the connection process in terms of DNS look-ups, new tcp/udp sockets being opened, authentication etc. In short why is this only working sporadically through the R7000? Could the robustness of the connection process need improvement?

I don’t think any of the wifi bridges or the 8Switch have span ports so I don’t see how I can capture a network trace to investigate further.

Any help you can provide would be most appreciated.

Kind regards,

Mike.

Hi Mike,

Not official support, just a friendly user trying the “low hanging fruit” kind of stuff. In Roon’s networking FAQ there is an entry specifically about the R7000, that might help. The entire FAQ is here.

Netgear R7000

We recommend disabling the “Enable Smart Connect” setting.

Thank you for your help Daniel. I’ll check that tomorrow. As the R7000 is in bridge mode I’m not sure it uses Smart Connect as I only enabled one band: first the 5GHz one, and then when things didn’t improve, the 2.4Ghz one. Nevertheless I will check and report back.

Hey Daniel, I checked the R7000 today and when in bridge mode there aren’t any options to enable/disable smart connect. I think this is because it’s for wifi clients that use the R7000 as an AP? There are some options in bridge mode to alter wifi parameters, namely Fragmentation Length (set to 2346) and CTS/RTS Threshold (set to 2347) and the selection of long or short preamble (long). Have no idea what these are, or if relevant.

Do you know if the Roon support folks will pick up this query, or is there something special I have to do to request their help? Thanks.

Hi Gort,

Yeah, I wasn’t sure if those settings would be available or not in bridge mode. But, I thought I’d pass on the official networking information.

And, yes, support should see this thread and respond. However, things are still a little backed up from 1.8. If you ping @support , that will ping everyone involved.

Cheers,
Daniel

Just to clarify the chain of connection is:

Internet > Router w/WIFI > Wifi > Netgear R7000 in Bridge mode > English Electric Switch > Nucleus+ and Devialet.

I’ve completed further testing: I saw that the Edimax bridge used a short preamble whereas the R7000 used a long preamble so I changed the R7000 to use a short preamble. On the R7000 I also turned off Beamforming and Airtime Fairness (I’m not sure these apply in bridging mode?). At this point I could now stream Qobuz albums. Yay. Power cycled the Nucleus+ and the R7000 and everything still worked. So far so good.

Switched the R7000 to the 5Ghz band (short preamble) and back to square one: no Qobuz album streaming. Back to 2.4Ghz and all ok. Left the R7000 on overnight and Qobuz album streaming stopped working again. Power cycled the R7000 and it worked!

Fed up.

Not what you want to here, but to troubleshoot I would take out the Netgear and run a cable to the EE8 to see if that solves your issue, even if its temporary it will help eliminate if it’s the wireless bridge that’s causing issues. I would say its likely that it is. Having core and streamer both on WiFi is asking for trouble. WiFi only works as single duplex and can only send and receive to one device at a time. Your getting latency due to both devices arw relying on one single wireless connection. Although the Nucleus will communicate to the Devialat over the wired switch connection, Roon is pulling and likely sending data back over wireless and this will take a hit depending on other WiFi traffic on your network , plus everyone else’s.

1 Like

Hello Simon, thank you for taking the time to read my post and your suggestions. To be honest I did not want to railroad other folk’s time but just wanted to ask Roon support for help. However it would appear they do not have a dedicated support email address.

Running a cable to the Nucleus+ is not practical I’m afraid but replacing the R7000 with the old Edimax works fine.

Hello @Gort ,

Welcome to the forum and thanks for reaching out!

As per our Networking Best Practices Guide, we strongly suggest against using WiFi range extenders in a Roon setup, as we have often seen issues surrounding these types of devices.

For best reliability, we suggest performing a direct Ethernet run to the Roon Core + Endpoints or if a direct Ethernet run is not possible then the next best solution would be to use a WiFi mesh network (like Orbi / Eero / Velop), that has a dedicated mesh backhaul for communication.

WiFi Range Extenders are a poor solution to the problems they attempt to solve, and we strongly recommend against using them for any reason. If you need to extend wireless access to a room and running a wire is simply impossible, a mesh network is a better option because it uses separate WiFi networks for “backhaul” (the connection back to the router) and for serving WiFi clients.

Hello Norris,

Thank you for your reply. Perhaps I was not clear in the description of the issue I’m having so to clarify: I am NOT using a “wifi range extender”. I am using a wifi bridge which has ethernet ports on one side and wifi on the other. The wifi bridge does not create an AP to extend the wifi. Essentially it acts as a wifi ‘client’ on behalf the devices connected to its ethernet ports. The only devices I have attached to the wifi bridge (via the 8Switch hub) are the Nucleus+ and Devialet of which only the Nucleus+ communicates with the Internet. This setup has worked fine for a couple of years (minus the 8Switch). It is only since the advent of 1.8 and use of the R7000 that the Qobuz streaming problem is occurring. Can you explain (or even suggest) why I can see Qobuz tracks, albums, playlists, etc but cannot stream the content? Thank you.

Hello @Gort ,

Thank you for the additional details here.

This may not be a typical “range extender”, but what you are describing here is known as a WISP Extender

WISP Extenders can also be just as problematic as a typical range extender because it relies on WiFi to perform the routing between the WiFi Bridge and the main router.

As a temporary test, would it be possible to bypass the WiFi Bridge and try to connect the Nucleus and one endpoint directly to the router to verify if the same issue persists in this configuration?

Hello Norris,

Thank you for getting back to me.

Regarding WISP mode and wifi bridge mode all I can say is the wifi bridge is only serving ethernet clients and not a mixture of ethernet and wifi clients (as per wisp).

Sadly I am unable to perform the test you suggest due to physical constraints.

To be clear: if I go back to my Edimax wifi bridge there are no problems, everything works fine. This would suggest to me that this topology offers a working solution.

I have now returned the Netgear R7000 as, after trying its wifi bridge in almost every configuration possible(!), it still does not work reliably. I guess I will have to rely on the old Edimax wifi bridge.

One observation I would make is that when using the R7000 the Nucleus+ ethernet port was connecting at 1Gbit. When using the Edimax (as it only supports 10/100Mbit ethernet) the Nucleus+ was connecting at these lower speeds (even when connecting via the 8Switch which is a 1Gbit switch). I wonder if this is area for further investigation, alas not by me.

One last question: I understand some folks are using usb wifi dongles with the Nucleus+. Do you know if these are working ok? Does Roon have a recommended model?

I imagine there is not much more to be done here if you want to close this thread.

Kind regards,

Mike.

This is possible, but definitely not recommended. We recommend an Ethernet connection whenever possible, as we note in our Networking Guide. It’s possible that some have had success with this type of setup, but if issues arise the first recommendation would be to use Ethernet.

Thanks for such a prompt response Dylan. Yes, there is no shortage of folks saying use ethernet. Apologies for my ignorance but can I ask why, with regard to audio, wifi appears to have such a stigma attached to it when everybody can streaming 4k UHD video to their TVs over wifi without problem?

Kind regards,

Mike.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.