Nucleus backup to PC

I want to be able to backup Nucleus to my PC on the network. Is it possible? I can not enter an address for PC that Nucleus accepts. I have tried smb:\DESKTOP-12BKDSD\M:\Roon Backup


I believe, and I don’t have a nucleus, that you mount the nucleus and drive the backup from the PC. That is for general file backup. Obviously the roon database backup is driven from roon.

Do it the other way around - run the backup software on your PC, and access the Nucleus over the network. Everyone has their own favourite backup software. I use Allway Sync for my music library.

Thank you for your answers. Should I understand that it is not possible to run a backup on Roon data file from Nucleus to a PC on the network. It does not seem that Roon accepts the network address I enter.


Yes. Pull from PC not push from Nucleus.

Ok. Another way could be to use a USB memory connected to Nucleus?


Just to be clear, you are talking about backing up your music files aren’t you? Backing up the Roon database is different.

No, I´m talking about the database


Oh, right. Then you want to first share the folder on your PC that you want to backup to on the network so that the Nucleus can see it. For example, if your backup folder on your PC is M:\Roon Backup, then it would be shared as \\DESKTOP-12BKDSD\Roon Backup. You’ll need a username and password to enable Roon to access the folder.

Hi @Geoff_Coupe
And thats what I do. Share the folder in the PC and the share \DESKTOP-12BKDSD\Roon Backup. the enter username and password. Only get “unexpected error”


OK, I’ve moved this thread to the Support forum, and flagged the support team for you with this: @support Let’s see what they can suggest.

I’ve just been trying this out on my system. I have a NUC running ROCK (so similar to your Nucleus). I shared a folder (H:\Roon Backup) on a Windows 10 PC to the network and then went to the Roon Settings/Backup screens to add a new Backup schedule using that folder.

First, I tried without including a username and password and then I did indeed get the “unexpected error” message

Since I had shared the folder while running Windows 10 with my Microsoft Account, I then repeated the add folder operation using these credentials. However, this time I got an “unauthorized” error instead:

That tells me that I need to use the local username in place of the cloud-based Microsoft account. You can see what the local username is by going to the C:\Users\ directory and using the name of your user folder, in my case it would be gcoup. So, using gcoup and my Microsoft Account password, and the new backup folder was added…


Hello @Geoff_Coupe
Thank you for all the work you done to solve this question. It works great!

I lift my hat in gratitude

Regards from Sweden


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.