Nucleus connect to Lyngdorf MP-60

Hello All

I have my Roon Nucleus connect via HDMI 2 to Lyngdorf MP60. When I try to play any thing it shows PCM 2.0.0 as input (even though I have two subs connected to Lyngdorf). Output also shows 2.0.0 No sub used.

If I change output on Lyngdorf to do Neural it shows 5.0.4 (it does use all my bed and overhead channels) but not Sub as input is not sending LFE.

Did I set up nucleus wrong?



Hi @Rajesh_Ramachandran,

Can you please share a screenshot of your Device Setup options for the Nucleus HDMI zone (Roon Settings -> Audio -> Cogwheel next to HDMI -> Device Setup) and a screenshot of your Signal Path when you have multichannel content playing? In the device setup screenshot, please show the option that shows how many channels you currently have active:

Attaching screenshot. Thank you

Hi @Rajesh_Ramachandran,

Thanks for that screenshot, but now we need the other one I mentioned:


I am not sure if my question came out correct. Most of my content are 2 channel (CD ripped or Tidal). When I stream it shows s channel and only its plays via my L/R speaker. This does not use my Sub.



Attaching the screenshot as well.

Hi @Rajesh_Ramachandran,

Thanks for clarifying. In this case, I would suggest you use DSP and perform a Procedural EQ -> Mix that sends the left/right to the back left/right zones and both left/right to the LFE channel. It should look something like this:

I don’t have a multichannel setup on my end to check these setting with certainty, but that should get you close to your desired output.

How do I get to that page?

Right click the zone name in the bottom right (says HDMI in my screenshot, might have a different name under your end) -> DSP

There is no righclick option with iPad. Let me see how to do it.

To access the DSP screen on iPad, you can click on the volume-speaker icon in the bottom right and press on DSP. That should get you to the screen, but not all options are available on the Roon mobile app, so while you may be able to toggle the option on/off you may need to initially configure the DSP from a PC remote.