Nucleus+ Core Not Re-Connecting to Network after Power Reset, Can only connect to Nucleus as Guest

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus+, Serial #54B203946A54104F, 4TB SSD
Roon OS 1.0 (254), Server 2.0 (build 1234)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
All devices are on the same network.
Netgear Cable Modem (Cox Gigablast up to 1Gb/s)
Netgear Orbi 860 Router, Mesh WiFi system (latest FW)
Peakedge SE26 24 port GigE Switch
Netgear 16 port GigE Switch
Linksys 4 port GigE Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Devialet D250 PRO v.13.1
Meridian: 218 (3u), MS600, Control 15 (2u)
AppleTV 4K (2u)
Airport Express (2u)
iMac 5K

Other Devices
Meridian Core on QNAP
Crestron Pro2 Controller
Crestron CNX-PAD8 (Audio Matrix Switch)
Crestron MT-MC2W Controlle


My Nucleus+ has been having trouble reconnecting to the network after power off or power reboot for the past few months. It’s the only device that’s not reconnected to the network after I shut down & power back up the system. It’s not showing up on my network even after rebooting the router and switches.

The Nucleus+ would connect to the network after multiple power rebooting in the past.

This time it didn’t work at all. I stumbled upon a workaround on one of the “Can’t Find Core” threads and connected to the Nuclues+ using Command K on the Mac Finder looking for “smb://nucleus” after several power reboot; however I can only connect to it as “Guest”. Is that correct?

The Nucleus’ default User is my Mac’s user ID but requires a password. I don’t recall ever setting up the user account on the Nucleus. Is there a way to setup my User ID and Password or rest the password?

Or, is there a default admin user and password for the Nucleus+?


Guest is fine for smb access. It’s the Mac’s equivalent of „anyone“. There is no user password protection for smb on the Nucleus

Not quite sure what you mean here. The only user ID and password on the Nucleus is your Roon account and the logins for Qobuz and Tidal, and you set all of them up in the remote app.
Plus logins for storage on a NAS but you don’t seem to have one

I got this pop up when I tried to connect to the N+

I can only connect to it as Guest:

What is the default “Registered User” log on? It’s not my Roon account ID and password.

As SuedKiez already mentioned, there is no account you can use to log in on the nucleus, other than the Guest account. What exactly are you trying to do, or hope to achieve by using a non-Guest account?

I’ve never seen that pop up log on window for the Nucleus+ Server before when trying to connect the Roon Core to the network before. The window defaulted to “Registered User” with my Mac ID as “Name”, so it’s confusing. If Roon users can only connect to the Nucleus+ as “Guest” then that’s fine.

The main issue is the Nucleus+ Core not showing up on my network after power reboot. I had to do multiple reboots and finally use the Finder Command K to connect to the Nucleus+ server.

If you’re connected to the file share, so you may browse local storage on the Nucleus, then the Nucleus is powered on and present on the network. (The Mac screenshot suggests it is connected.)

Consequently, it’s not clear what issue you have.

Incidentally, how are you rebooting the Nucleus Plus?

Ideally, you should open http://nucleusplus.local in a browser, and use the web interface to restart Roon Server (reboot is also possible, but not necessary in most circumstances.)

I used the web interface to power off or reboot, but when it couldn’t connect to the network I had to use the power button.

It took multiple reboots and using Command K on Finder to look for smb://nucleusplus before I could connect the Nucleus+ to the network. That’s the issue.

Hey @DN28,

Are you still running into issues here? If so, can you please replicate the issue and share the specific date and time the issue occurs?


This topic was automatically closed after 45 days. New replies are no longer allowed.