Nucleus+ crashes every night

Roon Core Machine

Nucleus+ OS Version 1.0 (build 254)
4TB Crucial MX500 SSD

Networking Gear & Setup Details

Netgear Nighthawk cable modem (Xfinity)
Trendnet 24 port gigabit switch TEG-S24Dg
eero Pro 6E AX 5400 WiFi router
Two eero Pro 6E AX 5400 WiFi access points (wired backhaul)

Connected Audio Devices

Linn Klimax DSM (2020 variant); wired ethernet connection directly from the Trendnet switch

Number of Tracks in Library

60,086 tracks

Description of Issue

I purchased my Nucleus+ from Moon Audio in Nov 2020 and, until recently, it’s operated flawlessly. Then, a couple of months ago, I started experiencing intermittent crashes of the Nucleus+, always overnight. The frequency of crashes has increased to (nearly) every night.

The Nucleus+ is connected to the Trendnet switch (with a short CAT5 cable) and nothing else (apart from the power supply). There are no other switches or routers in the network–all wired traffic goes through the Trendnet switch.

I have replaced the Nucleus+ power supply, and the cable connecting it to the switch (and changed the physical port on the switch). I have reinstalled the OS. My next step would have been to double the amount of RAM in the Nucleus+ to 16GB, but earlier posts on the topic convinced me otherwise.

Recent relevant changes include a Nucleus+ SSD upgrade (in Oct 2022) and installation of the eero router and access points (also in Oct 2022). These changes predate the crashing issue by several weeks.

I have included a couple of screen shots from the crash last night, which occurred between 3:00 am and 6:00 am. (The night before, the crash occurred between 11:00 pm and midnight.) The “Roon Database & Settings Not Ready” error is what I see almost every time (though once I saw nothing). I have been very reluctant to hit Reset, because I don’t want to lose all my library curation. I haven’t tried restoring the database from a backup, as I’m not confidant the oldest backup predates the crashing issue.

Thanks for any help!


Is anything else in your home resetting overnight? Is this a power issue?

You can try going to Settings/library and click on “clean up Library” and then go to settings/setup and click on clear cache. Then reboot the network and all devices on the network.

If none of this helps, you may need to either wait for Roon support to chime in.

Or some other ideas, make a backup of the DB and the try a reset. I would test the back-up by trying to restore it before the reset. You could also try some of your older back-ups, however they might be too old to work anyway if you just did a recent update that required a backup refresh. The worst that would happen is you are back to where you are now.
OR, if none of this works you might need to reinstall anyway.

Thanks for your thoughts. There is nothing else being disrupted on the network when these crashes occur, and I’ve tried cleaning up the library, etc. I think it’s odd that it only crashes overnight. At this point I’m going to wait for Support and keep fingers crossed.

1 Like

Here is behavior that seems odd to me, and may be associated with my Nucleus+ crashes.

I have Roon set up to backup to two endpoints, my Dropbox account, and a local Synology NAS server, each with a 4 day interval. Backups to the Synology server are set to start at 23:00. When I look at the backups on the Synology server from the Roon interface, they are not at 4 day intervals (see attached screenshot).

The Synology server logs (see attached screenshot), indicate that the Nucleus+ (IP address initiates a connection nearly every night, not every 4 nights. Some of these connections can be associated with a backup, but most can’t. Today (2/27) I forced two backups to the Synology server from the Roon interface, and it appears both completed properly.

My suspicion is that the crashes are associated with these connections to the Synology server, but I haven’t replicated it. And why the Nucleus is connecting every night is a mystery.


Hi @Nelson_Wright,

Unfortunately, the most recent diagnostics (timestamped to just before this comment) do not contain evidence of what precedes the crash. We’ll proceed with another diagnostic pull if you experience the crash overnight again.

Logs do show evidence that Roon is having difficulty mounting the internal storage location of the Nucleus+. Are you able to supply the tech support team with a screenshot of your Watched Folders location in Roon → Settings → Storage? Do you have content stored on both the NAS and the Nucleus+'s own internal storage?

If you have a recent reliable Backup, then it’s worth trying the Reset Roon Database & Settings option next time this occurs. You can also refresh your database:

  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • Reinstall RoonOs from the WebUI
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  • If everything starts up as expected Restore your Backup prior to the issue starting

Hi @connor,

Thanks for your response. Yesterday afternoon I went through the process outlined at, which follows the steps you recommend (except for the OS reinstall, which I did just now). I restored from the oldest backup I have, which is only about six weeks old–prior to my crashes becoming nightly, but I’m not sure I was crash-free then. If my database is corrupted, can I presume my backups will be corrupted too?

In any event, there was no crash last night. If it happens again, what should I do to make sure you can do another diagnostic pull?

All my watched folders are on the Nucleus+ internal storage (screenshot attached). It is a 4TB SSD. If Roon is having trouble mounting it, does this imply a faulty or failing SSD? If so, could this account for the corrupted database? Are there any diagnostic I can run?

I am posting this to document the resolution of my crashing problem, in case it is of use to others.

I first refreshed my database according to the steps suggested by @connor. (I had five follow-up questions for @connor which went unanswered, so I figured I was on my own after the database refresh.) My oldest backup was about six weeks old, so I used that one for the refresh.

This solved the crashing problem (i.e., no crashes over an eight day period, which included two scheduled backups). However, there was another issue: Roon would insert long (~15 second) gaps between some (not all) tracks. I suspect this was caused by corruption of the database I had restored from.

Finally I hit the Reset button for Roon Database and Settings on the Nucleus+ web page, knowing that it committed me to redoing all the curation for my library. Which I did over a 12 hour day yesterday.

In the meantime, I replaced the 4TB SSD in the Nucleus+ out of concern that it was faulty or failing based on a comment that @connor made.

So I have a new database and a new SSD, and Roon is behaving as it should. While I acknowledge that Roon support pushed me in the right direction (i.e., to trash my database and start fresh), I am disappointed in their lack of follow-up and in the lack of tools which could identify database corruption. I had to thrash it out on my own. The request I have for the Roon development team is to make the database more robust to common (and foreseeable) problems, and to alert users to corruption when it does occur.