Nucleus database backup

I am trying to set up the backup of the Nucleus database for newly installed Nucleus. I want to back up to my Windows 10 PC.

In Roon on my PC I select settings > Backups > Scheduled Backups > Add. On ‘Add scheduled backup’ page I ‘Browse’ Backup location. On ‘Choose folder to backup to’ page I click on ‘+Add network share’.

On the ‘Add network share’ page I paste the address from Windows File Explorer which is ‘C\Users\OWNER\Desktop\Roon Backup’ into ‘Network share location’. (I previously created this folder on the desktop.) I get ‘Could not connect to share: Host not found’.

Likely I am not entering the location correctly. I tried numerous variations of the address and get same result.

What am I doing wrong?

You need to create a share from your folder, then enter the share URI as “Network share location”:

It’s the same procedure, just add it as a backup location instead of a watched folder.

1 Like

So I did make the folder a shared folder. But still get: ‘Unexpected error’

So what is the address that you are pasting into the Network Share Location field?

Because if you are still doing this:

I paste the address from Windows File Explorer which is ‘C\Users\OWNER\Desktop\Roon Backup’ into ‘Network share location’

…that is NOT the correct address for your shared folder…

If I literally paste the address it pastes the following:
‘Roon Backup (file://TEDPC/Users/OWNER/Desktop/Roon%20Backup’

Clearly that is not the actual address. So I tried:
‘//TEDPC/Users/OWNER/Desktop/Roon Backup’

Then I check in the Properties of the folder the ‘Network Path:’ which has
‘\TEDPC\Users\OWNER\Desktop\Roon Backup’

Then I check in Properties of the folder where under General, the Location has:
So I tried:
‘\C\Users\OWNER\Desktop\Roon Backup’

Get ‘Unexpected error’ in all cases.

Obviously, I am not very tech savvy.

Well, yes - all those addresses are wrong, so not a surprise that you’re getting the error.

The trick is to enter the network address in the correct format, that is, of the form

\\<name of the PC>\<name of the Shared Folder>

and that’s it (and also the username and password required by Windows for access to the shared folder)


\\TEDPC\Roon Backup

1 Like


So tried that and get same result. I entered my username and I don’t have a password. I never setup a password for my PC and never need one to start the PC.

Oh god… :anguished: Not what I would do…

I think that you’re going to have to create an additional set of credentials for Roon to allow the Nucleus to explicitly access your PC’s shared folder - but others may be able to suggest an alternative way of accessing the shared folder.

For example, I set up a credential for Roon, with its own username and password…

Geoff, I tried that but get: ‘Windows was unable to find roon’

I also sent email to Roon support about 10+ days ago, but no reply.

Any more ideas? I will contact my dealer who sold me the Nucleus also.

If that’s an error message from Windows, then that sounds as though you haven’t created the “roon” user in Windows. You have to do that first before you can add the user credentials in a Folder share…

I did create ‘roon’ user. But same result.

Hey Theodore,

just one idea, why not just connect a usb key to your nucleus and back up there? it sounds much easier for me? your nucleus will be always running, might not be the case for you pc, back up to a network location adds potential errors.

once you have back up, we can figure out how to successfully backup to your pc.

This topic was automatically closed after 45 days. New replies are no longer allowed.