Nucleus+ lost sight of DAC [Resolved: upgraded USB input board]

Roon Core Machine

Nucleus+ Serial #94C6911AF494
Internal drive: Samsung 4TB

Networking Gear & Setup Details

Nucleus hard-wired via ethernet Cat6 to Gigaclear router via network switch and additional Cat6
Internet speed 800mbps up and down
Other devices hard-wired via same switch working just fine

Connected Audio Devices

Schiit Yggdrasil hard-wired via Audioquest USB
WD 5 TB My Passport Portable Hard Drive hard-wired via USB

Library Size

45,000 tracks

Description of Issue

I can no longer see my Yggdrasil as an audio zone when operating Roon - whether this be from my desktop, iPad or iPhone. I cannot link any event to this - no power cut, no software update, no unusual activity. Just… one day it was gone and I have not been able to get it back. I’ve checked all connections and leads - I’ve tried different leads - I’ve re-installed ROON server software and re-booted. Nothing helps.

Roon works fine on other devices - my desktop output, my networked KEF LS50s, my iPad, my Airplay connected devices. It just cannot find the Yggdrasil.

Please let me know if you have any ideas or if I need to return the unit for testing/repair. Thank you.


It could be a problem with the Audioquest dac?
Do you have another dac to try?
Roon can only see the yggy if the dac is on and functional

The Yggdrasil IS the dac. Audioquest makes the connecting usb cable.

Not thinking straight at all!!
Ok reverse course then.
As Roon cannot see the yggy dac is it possibly the USB connection at one end or the other?
Is this USB signal coming out of your PC or the Nucleus?

Do you have another method to connect to the yggy to see if it is just the USB that is acting up, or another problem entirely with the yggy?

Power cycle the DAC, and try a different USB cable.

I’ve powered the Yggdrasil up and down and tried an alternative USB cable - all be it a cheap printer cable - but it makes no difference

It’s a straight Nucleus-Yggdrasil connection. You don’t need a PC with Nucleus because the Roon CORE is integrated into it. I’ve tried an alternative USB connection but to no avail

Try connecting the DAC to a Windows PC or Mac to verify the DAC hardware.

What is the USB board? Gen 3, Gen 5, Unison?

Hi Peter

Good idea. I’m not sure I’m doing it right though… I disconnected the USB from the Nucleus and plugged it in to my MacBook Pro. So the Yggy was directly connected to the laptop. I couldn’t see it in system preferences as an output device, nor anywhere else on the laptop. The USB input looks like a standard USB-B socket. Schiit call it ‘Unison USB, our own USB input based on a general-purpose PIC32 microprocessor’. So I don’t know what Gen it is.

Am I hooking up the laptop wrong?

Thats why I asked where the USB signal was coming from as with the Nucleus you can go either way to the yggy, PC or Nucleus and it should work.
Trying to figure out whether it is the Nucleus USB output gone South or the yggy USB input gone awol.

Trying a different input to the yggy ( spdif or toslink if available).would be a test
Or trying a different USB source for the yggy like your windows PC?

Check this out:

You’ll also need to contact your DAC manufacturer.

1 Like

Sounds like the yggy USB input is an issue, see @wklie post above.

OK. Thank you. I feel the need to test the other inputs… I’ll need to borrow a source that connects via optical, coax, BNC or RES/EBU (whatever they are) because I don’t have one. Watch this space.

1 Like

I think you will find the other inputs are ok.
It seems Schiit have had a few USB issues in the past unfortunately.
Good luck!

I don’t doubt your other inputs will work. If the USB interface cannot be detected by two different computers, two different OS, with two different cables, it’s the USB module causing the problem. But the good thing is this USB module can be replaced / upgraded by DIY installation (although probably not trivial) or by the manufacturer at an additional cost.

Again you need to talk to your DAC manufacturer.

Sadly, I’ve had the USB section fail on my schiit DAC so not unique.

1 Like

Cheers Peter. I had reached a similar conclusion. Thankfully the Schiit importer in the UK is an excellent bloke and is already on the case.

Thank you. Though I feel your pain, it makes it less likely that I’ve messed up my tests to know that it’s potentially a known issue

Update - since I last posted 6 days ago my Yggdrasil has been back to Electromod (UK importer of Schiit and other cool brands). It’s been upgraded from Gen 5 to Unison and it is now back in my system and sounding awesome. Massive shout out to Mark at Electromod, who could not have been more helpful.

1 Like