Nucleus not appearing on network in finder window on MacBook.....roon still plays but I can't upload ripped CDs

Roon Core Machine

Nucleus with 4Tb Internal drive

Networking Gear & Setup Details

Comcast router, link sys switches, optical link to sonore ultra Rendu, then to Nucleus

Connected Audio Devices

USB connection to Okto DAC and Purify Eigentacht amplifier

Number of Tracks in Library

approx 25000

Description of Issue

Tried uploading ripped CDs from MacBook to Nucleus internal storage, can’t find Nucleus on network, did this a couple of weeks ago with no problem, nothing has changed since then

The Nucleus does not at all appear in the Finder under Locations > Network?

And this does not work? What happens when you try?

That’s right. That’s where “Nucleus” used to appear but no more!!

And if you attempt to connect to it explicitly by entering the smb path as in my above post, what happens?

Or by the IP address instead of NUCLEUS in that path?

1 Like

If I do that it asks for a password for the server Nucleus and none of my passwords work for that, and there isn’t one in the passwords list…there are other things in the network list but not Nucleus. Which IP address would it be so that I can try that?

I clearly should have included the green underlined part in my earlier screenshot

(which is from

In the meantime (from the KB),

If you’re running Roon Remote on Mac or PC, you can drag and drop music right into the app. Copies of the music you drag into Roon will be added to the Watched folder set up on your Roon Core.

Just so you can try to upload the music loaded while you are working on figuring out why you can’t browse the nucleus.

tried that…it says share does not exist on the server…I have used the drag and drop method in the past but the tracks didn’t stay in Roon and seemed to disappear. It does now work as to import music but I will need to wait and see if they hold. The Finder browsing method was more reliable and also enabled me to move and edit the library, which I needed to produce Flac copies for the car ( no more need with the advent of ARC )

The drag and drop method works fine but I do need to browse the Internal drive. I just managed to get the alternate method to work by making sure I used upper and lower case exactly as specified…you get used to more flexible entry procedures . So I can get that to work but it is confusing why the Network content changed. As I don’t do it very often this should work fine…thanks guys

Yeah, for better or worse Microsoft made the SMB protocol case sensitive

Drag and drop worked fine until Roon updated the system then the albums disappeared, which was the problem before. Have now tried the SMB method so we will see how that goes