Nucleus + not being discovered on network

Roon Core Machine

Nucleus+ REV B

Networking Gear & Setup Details

Google Nest Wifi
TP-Link Gigabit Network Switch

Connected Audio Devices

Haven’t gotten to this part in the setup process.

Number of Tracks in Library


Description of Issue

Purchased a used Nucleus + and plugged my Ethernet cable in. Pulled up the Roon app on my Pixel 7 Pro and the Nucleus could not be discovered.

I try hooking up a USB keyboard and HDMI out to both my TV and a monitor. No signal on either screens and no light on the USB keyboard.

Any assistance would be appreciated.

Judging by the icon on your avatar, you’re on a trial membership still.
Not that it should matter in this scenario, but a bit confusing.

Post a picture of the power supply which accompanied the Nucleus+, please? (Preferably with the specs visible)

Have you “seen” this device running? Dealer or private purchase?
I’d contact the seller either way!

1 Like

Hi Mikael,

I purchased this on US Audio Mart, seller advised it was purchased new last September. I’ve attached the photos for your reference.

1 Like

I am not seeing a light on the Ethernet port, are you sure the Nucleus Plus is turned on and operating? Also did the seller reset it so you can use it on your account?

I had it turned off when taking the picture. I can confirm there is power and Ethernet connectivity. I’ve reached out to the seller but in the meantime I tried Roon’s instructions to reset the network settings with no luck.

Well, it seems it is running in some way.
Can you have a look in your routers DHCP lease table, to see whether it tries to aquire an address?

If you don’t have any screen output, it is difficult to advise though.
Perhaps @support can be of assistance and see whther your particular Nucleus has been properly reset by previous owner etc.

And, it might be a good idea to try and re-seat the m.2 drive and mem-sticks internally, if something might have happened in transit.


I opened it up and everything seems to be tight and seated.

Hopefully @support can help me out.

Hi @Icipher84,

Thanks for writing in! Sorry to hear you’re having issues with your recently purchased Nucleus.

First thing I’d test - hook the Nucleus up to your router directly, and bypass all network gear.

After that, see if you can access the webUI of the Nucleus:

If you can’t gain access to the webUI, please pull up your local network settings and see if your Nucleus appears when you perform a local scan. I’d also completely power down the device and leave it unplugged for a few minutes before rebooting.

Let me know, thanks!

Hi there,

I tried plugging it directly to the router but I don’t see the Nucleus+ on my network.

You have a few “unnamed devices” in your client list, do you know what these are? And please give the HDMI-connection a new try, see if you can get any screen going, that’s really the best way to identify whats happening.

Worst case:
Error report, indication of hardware issues.

Best case:
A screen saying it’s retrieved an address, and which one…

Good Evening,

The unnamed devices are listed as wireless in the details . I tried both HDMI ports and was unable to get a signal out to my TV.

@support Please provide your guidance.

I tried connecting

Have you tried a different cable also? HDMI cables are (ime) unreliable, at best. I usually use a computer screen for this, but your TV should be fine of course.

I’m sure Benjamin from the Roon crew will be back shortly though, but meanwhile…

No feedback from the seller?

I tried re-seating the internal memory SSD again, used 2 different HDMI cables, but no luck. I am still not able to get visual.

Seller said they never used the HDMI so they never had issues.

Hi @support,

Just wanted to follow up on this request.

Hi @Icipher84,

Unfortunately, without being able to see any information displayed on the monitor via HDMI, or within your Roon account information (which would need the Nucleus to power on and connect to our servers properly) there isn’t much we can do to diagnose the issue better.

The typical next step here would be for you to send in the Nucleus via RMA for repair, in which there would be a cost associated, depending on what hardware needs replacing.

Let me know if you’d like to move forward with an RMA and we can get that started via private message.


1 Like

Hi Benjamin,

Yes, please shoot me a message.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.