Nucleus Not Recognizing Schiit Multibit Gungnir DAC

Core Machine (Operating system/System info/Roon build number)

Nucleus, Roon 1.7, Firmware 1.0 (build 183)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Nucleus has Ethernet connection to Linksys router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Schiit Gungnir Multibit DAC connected by USB (and also tried SPDIF)

Description Of Issue

I have a brand new Nucleus and have been unable to get it to recognize my 4-year old Schiit Gungnir Multibit DAC. Originally, the DAC was connected directly to my iMac’s USB port, with Roon software (including Core) installed on the iMac’s internal SSD. With this setup, I was able to use my DAC to send music to my audio system. A couple days ago, I purchased a Nucleus, then reconfigured my audio system with the DAC now connected to the Nucleus USB port. I updated the Roon software in the Nucleus, which now shows Firmware 1.0 (build 183) stable/, Version 1.7. My iMac still has Roon software installed, updated to Version 1.7. Nucleus is set as the Core, and I am accessing Nucleus from the iMac. I have not yet installed an internal drive nor connected an external drive to the Nucleus. I have activated both Tidal and Qobuz with the Roon software in the Nucleus, and I am able to stream music when I use my iMac as the endpoint. When I go to Settings > Audio, the only item listed under Connected to Core is Nucleus HDMI Output. Clicking the Scan for devices arrow does not change anything. Should I be seeing a Nucleus USB Output option (regardless of whether or not a USB device is connected)? Connecting my DAC and having it turned on and set to USB input has no effect. I have tried several USB cables, and have tried both Nucleus USB ports. I also have tried connecting the Nucleus USB port to a Schiit Eitr, which converts the USB to SPDIF, with the Eitr connected to the Gungnir DAC SPDIF input. In all these attempts, the Gungnir DAC does not appear in Roon’s Audio settings, nor do I get anything indicating Nucleus USB Output. I purchased the Nucleus after having seen SCHIIT listed on the Roon Web site as a Roon Tested device. However, in the Roon Device Setup > Find your device, I see a listing of devices that starts with and goes to WEISS, but the listing does not include Schiit. What needs to be done for me to get the Nucleus to recognize my DAC? Thanks in advance.

Hello @Jeff_Kane,

Currently, we do not have Schiit device icons in the Roon device identification database. We are working with Schiit to get these device icons into the app in the near future.

When you use the Schiit Eitr connected to the Nucleus, are you able to hear audio output on your Schiit Gungnir?


1 Like

I just bought a Gungnir MB. Taking delivery this weekend, and I hope I do not have this problem with my Nucleus.

A couple of years ago I had the Bifrost MB that worked fine in my setup with a Mac Mini.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.