Nucleus not resolving high res files through my attached DAC

I have an external usb 3.0 hard drive (MX files) and a Schiit Yggdrasil DAC attached to the usb inputs on my Nucleus and a network connection on the rj45. The dac was recognized but I am not able to resolve 96/24 or 192/24 bit files. Only the lower res files play. I have tried multiple settings through the device setup but have not been able to rectify this issue. The Nucleus and iPad software has been updated to 1.5 automatically after I installed the Nucleus. When I try to play hi res files it just lists through the album file titles and then stops without playing.

Please advise.

Thanks for reaching out, @Greg_Steele!

So we can gain some greater insight into what you’re experiencing, please verify the following:

  • Can you confirm that the DAC’s firmware is fully up to date?
  • Are you able to play this type of content to the DAC outside of Roon?
  • Can you share a screenshot of the signal path when playing to this DAC?
  • Does this behavior only occur when playing to this DAC? If you play to other endpoints do you see the same thing?


  1. DAC’s firmware is up to date. I also tried a Bifrost DAC connected to the Nucleus with the same results. Both of these DACs worked with Roon when the core was on my MacMini.
  2. Both DACs resolve 192/24 and all other resolutions on their own with no issues.
  3. I created another zone with the Bifrost DAC connected to my MacBook Pro. It plays the high res files from the Nucleus with no problem. I noticed it has integer mode selected in the device setup for the DAC. This option is not available with the Yggdrasil DAC connected to the Nucleus.
  4. I’m not sure which screen you are looking for on the screenshot.
    Thank you.

Hey @Greg_Steele,

You may need to contact Schiit and have them ship you an RMA board for replacement. You can read more about this here:


1 Like