Nucleus+ Not Seeing USB Drive

Just received my Nucleus+. After successfully installing an SSD and updating the version to 1.7 I attempted to restore my backup from my previous core per the migration instructions. I can’t seem to access the USB drive that contains the backup. Any ideas?

Yes, my problem is that the USB drive does not appear as an available location to restore my backup from.

Hi @Paul_Wishnoff,

How is the USB drive formatted? Can you share a screenshot of what the tab looks like when you go to Roon Settings -> Backups -> Browse?

Add images


I copied the back up file to a different USB drive and tried it, no change. This drive is formatted to FAT

Hi @Paul_Wishnoff,

How does your network setup look like, can you let me know the model/manufacturer of all your networking gear and how the Nucleus and the Windows Roon Client are connected? Is the behavior the same from multiple Roon Remotes/Clients (such as an iPad/Android if you have one as well)?

I was running the core 64bit version on my Lenovo Yoga laptop since 10/25 over WiFi with no problems. My remotes include the laptop, a Samsung S7 running Android 8.0.0 & Samsung Tablet running Android 6.0.1. The Nucleus+ is hardwired to a Synology RT2600ac, there is also a Synology MR2200ac hard wired for additional WiFi coverage. There has not been any other changes to the network.

Here is the info from the PC i was using as my core but is now one of the remotes. As it stands now, I’m concerned there is a hardware problem with the Nucleus+ and I will need to return it. Without being able to restore my backup I’m reluctant to continue with the migration, I’m effectively ROON-less…

Pardon me for jumping in, but it looks as though you’re using a USB thumb drive? I don’t think that the Nucleus recognises these. I’ve just plugged in an 8GB FAT32 formatted thumb drive into my ROCK/NUC, and it also isn’t recognised.

You could try restoring your backup over the network from your Yoga. Share the folder containing the Roon backup on the network, and then access it from the Nucleus…

It is extremely unlikely that there is a hardware problem with your Nucleus.

Hi @Paul_Wishnoff,

Thank you for providing those details.

No, I wouldn’t say that there is a hardware issue at the present time.

@Geoff_Coupe -

That’s certainly strange. I have a 4GB FAT32 which I just plugged into my ROCK running build 505 and it appears as expected in Roon.

@Paul_Wishnoff - Let’s proceed as follows:

  1. Have the USB drive unplugged from your Nucleus
  2. Reboot your Nucleus from the Web UI
  3. After the Nucleus has booted, plug your USB drive back in and let me know the exact local time + date when you plug it in (e.g. 8:59PM on 12/11/19)
  4. Verify if it still doesn’t show up in the Backups manager

Once I have this information I can enable diagnostics and take a look for additional clues.

I rebooted the Nucleus at 8:55pm on 12/12. I checked Backups manger and the the USB drive is still not visible. I also copied the Backup file to my PC and was able to access it from The Nucleus. When I tried to load the backup it seemed to load but after 2 hours the screen was unchanged. The back up file is 435mb+/-.

Hi @Paul_Wishnoff,

Thank you for rebooting the Nucleus and letting me know that timestamp. I have enabled diagnostics mode for you account and what this action does is automatically upload a set of logs to our servers for analysis. I can confirm that the logs have been received properly and I have requested some feedback from our technical team. While we wait to hear back:

Are you able to try using another USB drive? I wonder if there is perhaps something strange regarding this drive. If you are not able to use the drive, I would possibly try using exFAT as the file system format. Of course please only re-format the drive once you save anything you need from it to another location.

This could be the issue. I’ve just discovered that the Lexar USB drive I was using does not work at all with ROCK, no matter how it is formatted (but it does work with Windows 10), whilst another brand of USB drive works with both systems.

Hello @Paul_Wishnoff,

I spoke to the QA team regarding the diagnostics we received and it appears that the USB drive is not receiving enough power via the USB port to properly turn on and be detected.

What kind of drive are you using, does it have a model/manufacturer? Is it a USB 2.0 or a USB 3.0 drive? Did connecting a different USB drive show up as expected?

Earlier in the process I had tried 2 generic USB thumb drives, they are both at home so I am unsure what brand they are. Today I purchased a new USB 3.0 32G drive and was about to format it using exFat as the file system format per your previous instructions. I have some time this evening and was planning on working on it then.

1 Like

Thanks for that info @Paul_Wishnoff, do let me know how the other drive interacts with the Nucleus.

Success, the third drive worked perfectly. I was able to restore the backup and I am now up and running. Thank you Noris and all the other community members for the help.

1 Like

Hello @Paul_Wishnoff,

Thank you for the update here, happy to hear that the third drive worked as expected and your database is restored!