Nucleus Plus Does Not Boot

Roon Core Machine

Nucleus Plus Rev B, Purchased from Roon Direct

Networking Gear & Setup Details

Connected to Ethernet LAN

Connected Audio Devices


Number of Tracks in Library

Music files stored on another SSD

Description of Issue

I powered off the Nucleus Plus to move it to another location. I connected the ethernet and power cable and waited; then I scanned for the Nucleus to no available. I then plugged a HDMI cable to the
back (both ports) and connected to a monitor. No output.

Please advise.



I swapped the SSD and also the SODIMM. Still no output from either HDMI port. Thanks in advance for your assistance.

@Wes, @noris, @Rugby

Hey @phugo,

Ben here with the support team, I’m sorry to hear you’re having issues with your Nucleus! I will follow up via PM for next steps. :+1:

Well, with my newly purchased ROON, its app went black every time I tried to start it on my iPad. The app would show up when I clicked on it, then my iPad would go black screen. Reading around a bit, I found that my newly purchased ROON Nucleus did not have the latest firmware but my app was up-to-date. Thus the updated app would not talk to the ROON with outdated firmware. Once I went into the ROON via my MAC and forced an update of firmware, all was fine. I also forced a full reset. Maybe your firmware got corrupted during your movement. Give it a try, it can’t hurt.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.