Nucleus Plus is not recognized as the Roon Core

Continuing the discussion from Greetings!:


I’ve been testing with the Nucleus Plus, PS Audio and my MacBook Pro and found the following:

  1. The Nucleus Plus does not work, it is not recognized as the Roon Core.

  2. The one that has been recognized as the Roon Core is my MacBook Pro, instead of the Nucleus Plus. I can use the Roon with my PS Audio through my MacBook Pro, even with the Nucleus turned off.

As a test, I took my Nucleus Pro into my office, plugged in the Ethernet cable, plugged in another Mac desktop computer, and the Roon OS Device was unable to identify the Nucleus Plus.

It is clear that the Nucleus Plus has an operational problem and is unable to be recognized, and I am also unable to access the web to reinstall it.

I request help for this problem, and if it is not possible, I request the exchange of my Nucleus Plus because it is within the current guarantee.

I’ll try to send some videos in this email or later emails.

Kind regards,

PD: The Roon Core is working only with my MacBook Pro.

Try this for starters in hopes it helps you set everything up.

Your Macbook should be the remote, not the core.

You obviously have the Roon core software installed on your Macbook Pro in addition to that installed on the Nucleus Plus. That’s OK and actually advisable in case you want to take Roon with you somewhere. You need to deauthorize the MacBook Pro Roon core and authorize the Nucleus Plus Roon core.


Try plugging a monitor and keyboard into the Nucleus and post a pic of the screen.


Hi @Dick_Manrique,

I’m very sorry to hear that you hit a snag trying to set up your Nucleus plus. This may be due to having your Roon on another machine that was still authorized as your Core.

Please reconnect your Nucleus + to the network where you plan to utilize it and ensure that it is powered on. Then attempt to connect to the nucleus with this link:

Nucleus Plus link: http://nucleusplus.local

If you’re successful opening that link update your Roon software to the lastest build
Then open your Mac Core and go to Settings>General
Click Disconnect for the Mac in the Roon Core box
Then choose use this Mac as remote.

Please let us know if this helps.

1 Like

This topic was automatically closed after 44 days. New replies are no longer allowed.