Nucleus plus not able to use airplay

Roon Core Machine


Networking Gear & Setup Details

Asus router and blue curve from Shaw cable.

Connected Audio Devices

Sonos and B&W Zeppelin.

Number of Tracks in Library

Description of Issue


All my music will only play for 20 seconds and then stops.

Tried to see if it was one speaker so transmitted to each separately. I have made sure all updates. Rebooted my Asus router and blue curve from Shaw cable.

When I switch to Sonos streaming on only Sonos the music plays without stopping.

Can you give me any ideas?

The B&W is using cat 6 cable so I don’t use Airplay but Roon will not mix signals. I am not able to use my B& W now.

I also use a QNAP to act as a server. This is not the issue as the music streams on Sonos.

Kind Regards

Fill in the required information in your post about your set up.

Networking gear Asus RT-AX92U router
Blue curve Shaw cable in bridge mode

4 sonos ones v2 speakers and one Zeppelin hard wired via cat 6 cable. The rest are wireless setup.

12500 tracks stored on QNAP server. These play on my laptop with no issues via iTunes so not the issue.

Wen transmitting in AIRPLAY the Roon stops playing after 20 seconds. I have ungrouped and tried each speaker separate with the same issue.
When I disengage and enable the songs via songs stream it plays no issue. The zeppelin will not play though even hardwired.

I have had my Nucleus for two years and no issues other than the oddd up date and I rebuilt data base. I did this as well and it still does not work via AIRPLAY.

Hello @Anthony_Gray ,

Do you get any specific error messages in Roon when the stream stops?

I am not sure I understand, the issue is only with the Zeppelin or does it impact the Sonos airplay as well?

When you ungrouped, did you keep the Zeppelin in the group?

Does content from other locations work ok? For example, if you try Live Radio, does that have an issue too?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.