Nucleus suddenly no longer found by Roon

Like several before me, Roon suddenly is no longer finding my Nucleus (brand new a week ago). I’ve rebooted, power cycled, changed ethernet cables, even reconnected through a different switch. Power and ethernet lights are both on. It worked fine yesterday. I am able to access it through the web interface, and see this:

I’ve tried resetting the Roon Database & Settings, and rebooted from this screen as well. I’ve tried setting up a new core, but it won’t find the Nucleus to get started.

Finally, I’ve attempted to reinstall Roon OS through the web interface, which eventually times out:

it’s not the internet connection, however; when I use my laptop via the same switch and ethernet cable, I connect at 700 Mbps.
@support Any ideas?


Submitted the web form as well, with a link to this post for details, since @support has not responded so far.

Hey @Edward_Callaway thank you for reaching out to us about this, I’m so sorry that this has been your experience.

I hope it’s alright that we continue this conversation over email - I will be responding to your request on the web form for more information about this.

Thank you!