Nucleus will not power up

Roon Core Machine


Networking Gear & Setup Details

Netgear router, Ethernet

Connected Audio Devices


Number of Tracks in Library

No idea

Description of Issue

My Roon Nucleus is only a few months old. When I try to power it up the white power light flashes three times but the unit does not power up. I have tried the steps listed for other similar situations but nothing has worked.

Hi Ken,
please attach an HDMi screen to it’s output.
Report back what the display shows?

When HDMI is attached to a monitor the screen remains blank.

1 Like

In that case, if you’re sure the HDMI connection is good, either the M.2 drive, that the OS is on, went south or a component on or the motherboard itself has gone bad.

You’re still under warranty. If you bought it straight from Roon you need an RMA to get it fixed. If you bought it from a dealer, the next step would be to take it there.

Good luck.

@support supplies the RMAs.

Okay, what is an RMA and how do I get one please?

Hi @Ken_Nash,

I will message you with details and mark this as resolved.


1 Like

Thank you for your response. I failed to add that I bought the unit directly from Roon Labs.
Will you message me here or…?

Hi Ken,

I sent you a private message via our forums here. Just look at your notifications and please reply. I’ll take swift action!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.