NUC's boot disk can't be found [Fixed - SSD was not secured in the unit tight enough]

After a trip to the summer house, where I brought my headless Roon Rock Nuc, I failed to get it up running on the different network. In my attempt to get music in any way possible I then tried to get my old Mac Mini to serve as a Roon server (which was my former Roon server). My suspicion is that I some how messed it up in this process (dont know if that’s possible) and made it impossible for me to reconnect my NUC, without get it connected to a screen and keyboard. When I browse my router, the NUC doesn’t show “connected” despite I’ve got it wired with cable. When I tried to connect to the Mac mini in the same way, there were no problem…

I have no wired keyboard, but realise I probably must buy one to configure it, or…? What’s your advise? Easy problem to solve I hope…?

(My NUC is my primary source for music so I’m desperate to get this up an running as normal. Greatful for all help)

do you have the nuc set to a static ip address? is your summer house router set up with the same ip address convention as your main house?

for instance if you have a static ip address set for and the summer house router is set up as, then the nuc won’t connect.

I have no idea of the setting of the NUC (bought it second hand). The router does not have a static ip adress. I’ll have to connect the nuc to a screen and keyboard, I’ll get back when I have done that.

Hello @Karl_Wikstrom,

Thanks for contacting support, I’d be happy to take a look over this issue with you.

As @jcn3 mentioned, it is possible that a static IP address was set for the NUC, which can be a tricky situation to recover from if this was done incorrectly.

In general, most devices run on DHCP, which means the router gives the device a free address within the correct range. However, once a device has a static IP address, it will ignore the router it’s connected to, and will only use the static address. If this address is not formed properly, or even if it’s on a different range from the rest of the network, the device can be unreachable, which is obviously a problem with a “headless” device like a NUC.

If that’s what’s going on here, the easiest way forward will be to connect a USB ethernet interface to the NUC, since that will come up automatically as DHCP. This will give the device a proper IP address and will allow you to change the network settings for the main ethernet interface via our web interface.

There are other possibilities here as well. Something may have gone wrong with the hardware or the OS image. Are you seeing activity lights on the ethernet connection? Do you see any error messages when you connect a monitor to the NUC and boot it up?

If you have a backup of your Roon database and ROCK seems to be booting properly with a functioning ethernet connection, you can always reinstall the ROCK OS, but feel free to let us know the answers to the questions above and we can advise about next steps.


I never knew that. Might add one to my arsenal for future ‘scrabbling around for a keyboard and monitor after accidentally disabling network ports on headless computer’ situations. Would this work on Macs too?

Apologies to Karl for interrupting his topic

I just connected it to my TV, when rebboting the NUC, and on the screen it says “A bootable device has not been detected.” Sounds bad, but I’ll open the case to see if something has vibrated off…

Nothing loose here. Feeling lost…

Does “no bootable device” mean hardware failure? Or do I need to rewrite the OS? Why, what could have caused this?

I have no backup on the music files, but those are on the separate HDD (inside the NUC - see picture). Must I buy a disc to backup these files? If that is the case, how do I do that without a working NUC? (I have a MacBook Pro as a daily driver).

it most likely means the drive has gone corrupt or been unplugged.

since your visual inspection shows no cables unplugged, my guess is that the boot drive died (it looks like it is an M.2 SSD from your photo)

This is not very common, but heat could be the culprit.

It’s possibly still worth replugging the m.2 drive …remove the screw, pull up the screw end and pull the card out and reverse the steps to put it back

You should see both disks in the bios too…if you can get an hdmi tv connected and a usb keyboard to get to the bios

1 Like

Hello @Karl_Wikstrom,

As Danny has mentioned, this certainly sounds like a hardware issue. If the M.2 SSD has gone bad, obviously that will need to be replaced, and if you don’t have a backup of your Roon database, that data may unfortunately be unrecoverable.

For now, your next step is probably to confirm exactly what’s not working. You can try the SSD in another machine, or try a different SSD in the NUC. You might want to also tinker a bit with the cables connecting your hardware and see if any are loose or malfunctioning.

If you can access the SSD from another machine, it’s possible the Roon database is recoverable, so please let me know if that’s the case and I can recommend next steps. Hardware issues are always a bit tricky, but please let me know if you need any advice about moving forward here, or if you have any questions about my suggestions above.


2 posts were split to a new topic: HEED OBELISK DAC + SOtM dCBL-U2 - Not showing as an available audio zone