Once a week or so the ROCK disappears

I recently built a NUC Rock with tremendous help from this forum… thank again to all those that helped. Its been great and typically rock solid
Once a week or so i loose contact with the ROCK. The NUC is still on but it drops from my network. The situation is remedied by restarting my Router (Goolgle mesh) and then restarting the NUC. I suspect this has to do with the dynamic IP addressing that the google router tries to hand out.
Ive tried to reserve the NUC’s IP address within the goolge networking app but the problem seems to persist. Is there a setting that im missing or incorrectly set that is causing what should be an easily remedied problem

12 posts were split to a new topic: Once a week ROCK disappears from network

I’m having a somewhat similar issue with my NUC8/ROCK. Mine usually doesn’t drop off the network, but instead just stops responding to Roon clients and I have to restart it.

How is your NUC connected to the router? Is is plugged into the router itself, or through an intermediate switch? I was thinking you might have a flakey ethernet port/cable and to try another one.

In my past IT experience I’ve come across the rare instance when two ethernet devices just don’t seem to negotiate well. In those cases I’ve had success by putting a small ethernet switch in between to act as a middle-man. Do you have a switch laying around?

Unplug the power to the switch.

Use a different cable for the ROCK to a different port in the switch.

Power on the switch after a few minutes.

Interesting - I also have it plugged into a Netgear Prosafe GS (G116 - 16 port).
Hmmmm, I wonder if it could be related to the NIC driver that Linux is using on the ROCK?

I’ll wait for one more ROCK update and if doesn’t make it more stable, I may switch the NUC over to Windows and see if that does a better job with long term stability.

Thanks ill give it a try this weekend…
Interesting though that Thomas is having the exact same issue with a similar switch

I finally determined what was causing the issue. Surprisingly it was the device I was running the Roon app on. In my case it’s a cheap Amazon Fire HD 8 tablet.
Yesterday the ROCK stopped responding again. I decided to fire up my laptop and see if things were any different when using the Windows app. On the laptop, the ROCK was behaving perfectly! It was strange - the tablet was displaying the ROCK supposedly trying to play one thing, while the Windows app showed something completely different.

After rebooting the tablet and re-running the Roon app, it started working again.
So, for me anyway - this entire time I’ve been experiencing trouble accessing the ROCK, it’s been the darn tablet the entire time. I always leave the tablet powered on and sitting in it’s charging stand. I suspect, that after a few days something goes bonkers with the Roon app and I lose access. This just started after the latest Roon update by the way, because before I had no issues with the Fire tablet & Roon.

I reinstalled the Roon app on the tablet to see if that fixes it, otherwise I’ll have to replace it with a Samsung or something.

Good finding.
Next time don’t reboot it. Just turn off WiFi and on again.

If you have 5GHz in both the router and the tablet, use different SSID for the two WiFi bands, and set the tablet to use 5GHz WiFi.

Guess what - that wasn’t the issue after all. I had the problem again on the tablet where Roon said it was playing files directly from the ROCK to my DAC when it wasn’t really doing anything. Toggling WiFi on & off didn’t help (I always have had different SSID’s for the 2.5GHz and 5GHz bands). Rebooting the tablet didn’t help. Rebooting the DAC didn’t help. As before I then fired up Roon on my Windows laptop and discovered it also couldn’t control the ROCK. I had to reboot the NUC running ROCK to get Roon working again.
So, its frustrating as this issue has happened 4-5 times and each time the solution varies. Sometimes resetting the tablet restores functionality - sometimes not. One time unplugging the USB cable between the NUC and the DAC worked. What has always worked is rebooting the NUC.
This issue started soon after the recent Roon system update to build 511.

Note: I had an iFi USB Purifier on the USB cable between the NUC and the DAC. I have removed that to see if that could have been causing a communications issue between the two.

Do we have a bug in ROCK here? Is it worth taking a deeper look?

Good question. Maybe.
I’ve had the NUC running ROCK for 4 months. It was very stable until the last update. What makes this a tough problem is it can run just fine for 4-5 days. Most of my listening is done with the DAC that’s connected to the NUC via USB. I recently removed the iFi USB Purifier that was at the end of the USB cable from the NUC to the DAC. I’m waiting to see if that makes any difference.

Here is my general setup:

8GB RAM (Corsair)
250GB NVME (Mushkin)
Ethernet wired to Netgear Pro switch with static IP

Music files are on a NAS.
Denafrips Ares II DAC
Audioquest Forest USB cable connecting the NUC and DAC

Are there any logs kept by the ROCK software, or maybe a debugging mode?
On the ROCK homepage there’s a blue OS ReInstall button. Can anyone tell me how that works?

Whew, I think I’m ready to sate that my issue has been solved. It’s been 9 days since I took the iFi USB Purifier out of the USB connection between the NUC and the DAC. And… it’s been running just fine. So, I’m assuming the iFi device was intermittently interfering with the USB communications.
Also, I might add is that I can’t hear any difference with the sound quality with the “USB Purifier” out of the system.

1 Like