Once a week ROCK disappears from network

I recently built a NUC Rock with tremendous help from this forum… thank again to all those that helped. Its been great and typically rock solid
Once a week or so i loose contact with the ROCK. The NUC is still on but it drops from my network. The situation is remedied by restarting my Router (Goolgle mesh) and then restarting the NUC. I suspect this has to do with the dynamic IP addressing that the google router tries to hand out.
Ive tried to reserve the NUC’s IP address within the goolge networking app but the problem seems to persist. Is there a setting that im missing or incorrectly set that is causing what should be an easily remedied problem

to test this theory, set your ROCK to have a static ip in the ROCK web ui.

HI Danny
Ok, i et to static IP and used all the previous parameters. I then reserved the IP in the Google Wifi web browser.
Everything appears to be working
Now what?

Thanks

wait to see if it falls over? :slight_smile:

1 Like

it fell over last night again…
Any thoughts?

ok, so… there goes the theory that it has to do with the router’s dynamic ip stuff

next, let’s try this - just unplug the ethernet cable, wait 5 seconds, then plug it back in… does that fix it? it’ll be good info for me to debug.

Instead of, or in addition to, setting a static address on the ROCK machine, go into your router software and reserve the address.

FWIW

things ive tried so far, all of whihc have failed;

  1. Set router so that ip for rock is reserved
  2. Set router and rock for static ip
  3. When rock is missing ive unplugged cable and then plugged back in. No change

the only thing that seems to work is to shut off router then reboot rock. Happens once a week. Router always hand out same IP even though i now have this unreserved

Thomas

I think you nailed it. I have exactly the same issue. I can see the ROCK on my network but cant see Roon from and interface.

The switch between my router and roon is a Negear Prosafe GS 108. You?

Ive had no other issues betwee any device and this Switch or the Goolge router

Thomas;
Still no real change on my end;
I tried switching cables and ports on my Netgear switchr along with a hard reboot. Still no change with the Apple ipad showing a lost connection by weeks end.
As an aside i was thinking of up guarding my home mesh network. The new router which will replace my old google mesh has more ports. This way i will be able to bypass the switch all together. This will tell me if its the weak link… although this does feel like a stretch.
Interestingly all this started around the second week of January. Prior to that the setup was rock solid so it may be a bug in the latest release?

@support

… Is there away to get ROON to respond or be made aware of this issue?

tagging @support.

Hi @neil_kaye,

I have split your posts into a #support thread so that we can better focus on this issue. I have a few questions/suggestions:

Just to confirm here, if you only reboot ROCK, does that get it back to working mode or do you have to reboot both router + ROCK?

Are you still able to access the ROCK Web UI when this issue occurs? If you are - can you please share a screenshot of the WebUI?

When this issue occurs can you connect an HDMI/Displayport cable to ROCK and see what it says on the monitor? Does it receive an IP address there?

I agree that bypassing the switch would provide some useful information, that way we can see if the switch is playing a part into this issue here.

What Roon Remotes/Clients are you using to control ROCK? Does the same behavior occur on all of them or just one/some of them?

  1. I need to reboot both router and ROCK. I have tried to just reboot ROCK ass well as removing ethernet cable. Both of these actions dont resolve the issue
  2. Since ive only used my IPAD to access the ROCK i haven tried the Web UI. I will try to access the UI from a laptop when it happens again (probably this coming Sunday)
  3. Unfortunately i dont have a monitor at home so i cant try this. However speaking of visibility, i can see the ROCK on my network through my Router software when it disappears from the Roon interface i.e. the NUC that runs ROCK, at least from the router side, appears to be running
  4. (no comment)
  5. Great question. I have always focused oon getting my IPAD client / remote up and running again. When the issues happens again i will try my client that runs on my iphone. I also have another client running on an imac that i will check.

Thanks for your help

1 Like

I am only using the iOS client but the behavior is consistent across all devices (ipad, iphone etc)

I also switched out my router from a google mesh to a netgear mesh. Some issues arise within the week although on a different day now (before it was Sundays)
Minor change is that i only need to reboot the ROCK now to get it to come back online where before i needed to reboot the router and ROCK

Hi @neil_kaye,

Just to make sure I’m understanding you here, this issue occurred only on Sundays before? That’s interesting - do you have any timers set to run on Sunday? Timers that reboot your network or anything like that? What day of the week is the behavior occurring on now, or is it seemingly random?

When the ROCK is not on the network, are you still able to access the Web UI? If so, could you please share a screenshot of the WebUI when the ROCK is in this state?

Hi Noris,

Ill need to wait for the ROCK to go offline again and ill check if the Web UI is accessible.

And in terms of the schedule, yes it was every sunday (early morning i think) that the ROCK went off line… like clockwork. Because it was so routine and there are no timers that im aware of, i thought it was related to the Google Router handing out new IP’s. I did try to set static IP’s but that didnt help, in fact with one configuration (Google and ROCK set to to static i couldn’t see the rock at all) With my new router its only been done once and that was last Thursday… ill have to wait until this Thursday to see if the same happens again

1 Like

Thanks for the info @neil_kaye. Do let me know if the WebUI is still accessible when/if this issue re-occurs or if it does happen on Thursday.

Usually the DHCP leases I’ve seen are 24 hours, but if you have a custom lease time it is possible, although now you have reserved it and set a static IP I don’t believe the DHCP handouts could impact this behavior.

The ROCK went went ‘down’ again last night

  1. When missing from the iOS app i could still see it on my network and access the web UI (see attached image)
  2. After i rebooted the ROCK the problem did not resolve itself.
  3. Onnce i rebooted my router, and a new IP address was issued the problem was resolved (this has been typical
  4. As a correction the IP for the ROCK is set as dynamic (see attached)
    Pleae note that in the past when i tried to set as staic the problem did not resolve buit i might have done it incorrectly

Looks like image 2 and 3 got reversed in the post. The UI screen grab that indicates a problem with the Roon database and setting is the UI when the ROCK ‘disappears’. This resolves itself with a new IP

Hi @neil_kaye,

Thanks for those screenshots. It does indeed look like the IP changed and could be the cause of this behavior.

Have you followed Google’s instructions on how to do this? I also found this Youtube video which highlights the steps on how to do this:

Once you set a reserved IP, it shouldn’t change. I believe it’s worthwhile to take another look at this and try setting the Reserved IP again, can you please give this another try?