One DAC 1 PC and a Mac - Known Issue?


While using the previous version of Roon I was able to switch between my PC and MAC at my desk via a USB hub and have no issues with my DAC showing up in Roon on either my PC or Mac after switching back and forth. Since the update I havent been able to do this.

Now the DAC only shows up on my Mac and if I switch back to my PC I cannot pull up my DAC as an audio zone.

Any ideas?

Thanks for the help.

Please explain your setup in more detail. What device is rubbing running Roon Core? How is everything connected?

My Roon Core is a Mac mini on a completely separate machine. All three computers are connected to the same network. I have a powered USB Hub and A/B selector that I use. All of my USB gear is plugged into a powered hub and then I have a USB switch to switch between my work Mac and Personal Laptop.

When I go back and forth between machines I push the button and select the Machine. On Roon 1.7 I could switchin these machines, open roon on each computer, then select my DAC and play music.

Now when I switch machines the audio zone does not show up and only shows up on my Mac. I am guessin that I registered the DAC to the Mac first and when I switch back to the PC it no longer will show up becuase it should be registered to the Mac. That said, on 1.7 I had no issue switching between the two.

Also, the PC picks up the DAC just fine and I can use it to play music through Qobuz and Tidal. It’s just roon that doesnt see it.

Have you tried connecting the DAC directly to each machine? Does Roon identify the device and play as expected? If you then connect to the switch is the device remembers?

What you have is an unusual and dare I say unsupported and atypical setup.

I will try that but, yea, point remains that I never had this issue on the old version of Roon. What if I was using a Dragon Fly Cobalt between two machines in my house? That is a more “mobile” device and one could reasonably expect you’d use it on other devices Like an iPad, iPhone, and PC.

I just unplugged the DAC (Ares II) and put it into my PC directly and it isnt showing up under Settings>Audio.

My PC sees the device but roon isnt. I am also hitting the refresh button to no avail.I think there is some rule or soemthing in the software that has it locked or stuck on the Mac.

Have you installed the latest release? There are other reports of missing devices in the forum, so it may be worthwhile reading those threads. Also, move this thread to #support, so Roon staff see it. Let me know if you’d like me to have the thread moved for you.

Yes, I have the latest release.

If you could move it that would be great. Sorry I thought I posted this in the support thread.Thank you for the help.

Update: Plugged in another DAC and realized that Roon is failing to even see my PC as and endpoint all togther. Tried both hardwired and wireless. No luck.

Can someone from roon support please advise?

I have rebooted my core, restarted my network, uninstalled and reinstalled roon on my PC and still the Roon core is not seeing my PC as an audio zone. I have tried two different DAC’s, Ares II and DragonFly. None of them are showing up. I also turned off my firewalls.

The windows client can see my core but the core does not see my windows PC. I am at a loss here. I dont know if it is a networking issue or a software issue but this issue only showed in since 1.8. Do I need to do a fresh instlal of the core software at this point?


AHHH - I think I figured it out. I had my network set to “Private” and that is what it should be set to but I toggled it from “Private” to "Public’ and then back to “Private” and that seems to have done the trick. Looks like it was a firewall/network setting glitch.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.