Open GL 3.0 Fatal Error (GL_ARB_framebuffer_object extension is missing) [Answered]

I often get an Open GL 3.0 fatal error when launching Roon on a Remote instance of Roon running on my main PC. I have a dedicated headless RoonServer that is the Core. All music files are served from a Drobo NAS or TIDAL. The fatal error dialog indicates “GL_ARB_framebuffer_object extension is missing”. On the Remote PC, I have dual nVidia GTX 1080’s in SLI with current drivers (just updated to a new version today) so my graphics cards and drivers are certainly up to date. Usually a reboot will allow Roon to launch. However, just now I had to reboot 5 times to get it to launch. This is clearly a bug or incompatibility with some aspect of my hardware or software. Is this a known issue and what are possible workarounds? Uploaded screenshot of error dialog. Thanks!


Hi @Thomas_Blake ----- Thank you for the report and my sincere apologies for the slow response. I had a chance to touch base with my team yesterday to discuss what could be causing this issue to occur and we would like to please have you try the following procedure:

  1. Uninstall the nVidia GTX 1080 driver.

  2. Visit the nVidia website and re-download the most recent driver update, along with a few past updates. Let’s say, no more than 2.

  3. Install one of the previous drivers and restart the machine.

  4. Once the machine is back online, try re-launching Roon. Does the problem occur?

If you are not met with the same issue after the rollback…

  1. Move to the next update and repeat the procedure to confirm where this is failing.

Looking forward to your feedback! -Eric
FYI: After each uninstall/re-install it is important that the machine is rebooted.

Hi Eric,

Thanks for the reply. This error seems lessened with the Windows Creators update. It has only happened once since I installed that earlier this week. My main PC is primarily used for gaming so I am not willing to roll back to a prior version of the nVidia drivers. I can uninstall/reinstall the current driver and see if that helps. Is this a common error? Worst case I can always use an iOS device to control my dedicated Roonserver. Roon runs so much better now on a dedicated server rather than having my main PC be the Core. I am also using a microRendu to provide the USB signal to my DAC and that has improved the sound quality tremendously.



Hi @Thomas_Blake ---- Thank you for following up with me and sharing your observations since reporting this behavior to us. I would not say this is a common error necessarily but it is one that we have seen before.

As you are aware Roon’s interface depends on open GL drivers working as expected and when receive reports like this it is always traced back to some sort of driver related issue. Please keep us update on any new observations you make, and if you decide re-load the driver or test with other versions please let us know how it goes.


H Eric,

I did uninstall all elements of the current nVidia driver (Driver, GeForce Experience, PhysX, 3D Audio, etc.). This is version 381.65. After reinstallation I am still getting the same error. It is not on every program launch, but occurs maybe 50% of the time. This issue has persisted through the last few nVidia driver updates. I am not willing to rollback from the current nVidia drivers so I guess I will live with it. It can typically be resolved with a reboot or two. Worst case I can use the iOS app to control my Core, which is now on a dedicated server. Have you pinned this issue down to specific element of the nVidia drivers as I don’t use all components? If it is the video driver itself than there is no way around that. Seems odd that Roon won’t coexist with the current nVidia drivers though.

Can I ask one quick question - if I enable upsampling in the DSP engine is it the Core machine that performs the upconversion or if I initiate from a remote PC is it done there? My remote PC is FAR more powerful than the Core server and would be nice if the upconversion can be done from the more powerful machine. I assume upconversion requires a beefy machine to perform well? If restricted to the Core can this be changed in the future? I imagine it is a common use-case scenario to have a low powered machine as a Core server with a much more powerful PC used for remote access.



I don’t think it is the Driver per se. I’m running that version and it (and Roon) are solid as a rock. (no pun intended). However, I am only running the driver and PhysX, I don’t install any of the other audio or experience options.

Is that the LG 38UC99-W 38" running in 3840 x 1600 Resolution?

I’m wondering if the unusual resolution or because you are running in SLI might be behind your issue. Its been a long time since I had SLI working (EVGA GTX 260 Core 216); but, back then I would get weird issues.

Yes it could be due to SLI. That is a good theory.

I did uninstall all parts of the nVidia drivers I don’t use and only have the video driver, PhysX, and GeForce Experience left installed. We’ll see if that helps.

My monitor is an Acer Predator X34 running at 3440 x 1440.


I would knock of the Experience software, as well.


How do you overcome this problem? I just loaded Roon on an NUC and I’m not having any luck with it.

Some additional information is helpful. While the error maybe the same as the original post, you are using different hardware. Additional information would be helpful such as:

What are the specifications, model number of the NUC, what is the OS and version number.

Thanks Daniel. My NUC is a NUC7i7BNH operating on Windows 10 Pro build 15063. I just downloaded Roon last night so it should be the current version.

Try the 32 bit version of room if you are not using it already.

I just installed and ran the 32 bit version with the same results.

Hi @vgrubb ---- Thank you for the report and sharing your feedback with us. Both are appreciated, sorry to hear of the troubles.

Moving forward, may I very kindly ask you to please give this knowledge base article a read (I’m getting an OpenGL error trying to start Roon, what’s going on?) and run the listed utility to verify which version of OpenGL your system is capable of running.


Thanks Eric. I ran the driver update in device manager and it said my drivers were up to date. I ran the utility but didn’t pay for the service. It is hard after investing $800 in the NUC and operating system to have to pay for a subscription to check a driver. I know its not much, but its the principal. I’m running RoonServer and it is operating fine. My server is in a closet area so this works just fine. It may even be better with less running on the server. I may down the road try this utility just to see. I appreciate the help.

You didn’t specify but do not rely on drivers coming from Microsoft. Download the drivers from the manufacturer directly. The latest video drivers are Version:

You can get them directly from Intel Here:

1 Like

Thanks Daniel. That cured it. Roon is launching fine now. I appreciate the help.

No Problem. I tend to install all the drivers new from the manufacturer, so besides video, the network drivers, etc etc.

This topic was automatically closed after 18 hours. New replies are no longer allowed.