Open GL 4.4 Still Not Working

with Roon.

Can you try running this utility and let us know what it reports?

It is working for me on the latest Nvidia drivers, 375.70

Mike, the pics you see above were all taken from that app. The nVidia screenshot in particular you see its from Open GL Ext.Viewer v 4.4.

But here it is again, w. the name.

So all strange. I also updated to latest 375version. I hooked up a monitor to my pc and this is what allowed me to at least get OpenGL 4.4. I can open Roon successfully directly on the pc…(and even then, I get cannot find HQP transport despite using HQP directly works flawlessly)

It seems to be a Microsoft Remote Desktop problem. I cannot open Roon with that same darn warning, need at least v.3.3 of OpenGL. If I open the OpenGL Viewer on the iPad/RD, it changes back to Generic Renderer v1.1.

The whole point of having the PC in another room, so one can use a remote headless operation.

I sure hope we can get this worked out as I haven’t used Roon in a very long time. I last posted this awhile ago, it worked once, and then back to this problem so I’ve just not used Roon. I want this to change :wink:


Just a casual observation … why are you using Remote Desktop to control Roon, installing Roon Remote would yield a much better user experience?

Can you just clarify:

  • With a monitor connected directly to that PC, does Roon run ok?
  • Is the problem only when attempting to use Windows Remote Desktop to that PC to run Roon?

As this PC is normally headless, the recommended installation would be Roon Server (No GUI, No requirement for OpenGL3.0 or higher). Then you would use Roon Remote to configure and control Roon Server.

Would this be an option for you?

And to pile on if @Carl 's suggestion doesn’t work, you can use the free Teamviewer app. Works great, imho.

Sure, I can use the Roon Remote just fine…

I was just using RD to also access Roon when using HQP as it was right there and thought I could easily use both, RD and Roon Remote. I’ll just stick with Roon Remote then.

Thanks guys for the education :wink:

[quote=“fore, post:8, topic:15788”]
Thanks guys for the education :wink:
[/quote]Hi Chris,

We were trying to help, some users are not aware of Room Remote and Daniel’s suggestion of using TeamViewer rather than remote desktop is quite pertinent. So I hope you were not offended by our suggestions.

I’ve removed the HQP question as it not related to Open GL issue (rule of thumb different problem, different topic), thus I recommend starting a new topic for that or continue in your existing topic though I note it’s quite old and marked as solved.

I ran into this myself before I was a Roon employee. Basically, RDP will report v3.3 back to the Roon app, so it won’t start; I never found a solution to this. However, if you start Roon on the physical PC and then RDP to it, this solution will work.

There are a few topics on this out there.
Teamviewer works. Vnc also wirks.

As does having Roon autostart. Or starting Roon manually on the machine. And then rdp-ing in.