OpenGL 3.0 problem

Hello Ive read most threads concerning my problem and still wasn’t able to solve.

I keep getting the following error message when trying to open Roon:
OpenGL 3.0 or Higher is required. The video drivers on this system do not support OpenGL 3.0 …
intel site and still, unable to solve the problem.

Ive uninstalled and installed Roon twice, I ran a driver update session on the intel website and still, nothing works…

I<m running a windows 10 based computer to listen to music and its hooked to my Samsung flat panel tv.

Help please


What is your hardware configuration?
OpenGL is related to the video card/chip, so if it is old, that might not be supported.


Brand new music and video server:

Windows 10 Pro 64 bit
Intel i7 6700 cpu @4.0 ghz
Ram 16gb

Do you have built-in GPU or you are using 3rd party video card?

If you only want to use it as a server, then please install RoonServer (that’s separate package), which shouldn’t require OpenGL.
Do you use a built-in graphics?
If yes, you will need latest drivers from Intel. That CPU should support OpenGL 4.4 according to Intel.
If you use 3rd party video card, do you have their latest drivers?


I need core and thats what ive always been using before it suddenly stopped working a couple weeks ago after a windows update.

Concerning your question, where canI find the answer? Built in or 3rd party, how do i know that?

Ive installed all intel updates today still doesn’t work.

In Windows Device Manager, what do you see under Display Adapter?


Could you please expand the Display Adapters in Windows Device Manager and take a screenshot (and post it here)?


I just cannot paste ant image to this screen

Is says its a Microsoft Basic Display Driver, Version 10.0.16299.15 and that the driver is the lastest version available.

Tks guys

Note : I<m running Tidal and JRiver without those kind of issues. Concerning Core vs. Server, I<m using this computer to run Roon, it displays on my Samsung flat panel tv and the sound output goes to my Lyngdorf TDAI amp through AES-BNC. I am also using my ipad and iPhone to control Roon on the same system


Looks like Windows doesn’t recognize the actual adapter hardware, and installed the bare-bones driver.
That driver will not support OpenGL 3.0 needed to run full Roon.

You could try and run RoonServer:
If you do, you can control it using iPad/iPhone/Android, other Windows/Mac computer.
Or, you could try and track the video card your computer came with by contacting the vendor who sold you your machine. You will need a video card brand to know where to get the proper drivers.


Hi, I have updated the trust level on your forum account … it should allow you to post images now.

Those applications do not require Open GL, so would be unaffected by what’s changed recently on your system.

I’ve had problems with OpenGL on two systems. An old Acer netbook simply had a graphics adapter that couldn’t support OpenGL. Then a HP Pavilion laptop with AMD Radeon graphics. It was working fine but a windows update replaced the graphics drivers with ones that weren’t right with no support for OpenGL. Using the latest AMD Radeon drivers wouldn’t work either. Eventually I went to the graphics drivers provided by HP and they worked. It was a painful journey to get there. Now I’ll know what to do when another windows update corrupts the graphics setup.

Suggest you find out exactly what your graphics system is and then install the right drivers. Like me you might find that the generic drivers provided by the graphics chipset manufacturer don’t work. You might need to find the graphics drivers provided by the manufacturer of your display card or motherboard.